Bug 1307023 - Hibernation doesn't work on Skylake Core i7
Hibernation doesn't work on Skylake Core i7
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 08:15 EST by romu
Modified: 2016-09-27 07:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-27 07:32:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot when the computer is stuck at shutdown (43.54 KB, image/jpeg)
2016-03-17 06:46 EDT, romu
no flags Details

  None (edit)
Description romu 2016-02-12 08:15:59 EST
Description of problem:

On my Dell XPS13 (9350) with Skylake i6x00 Core I7, the F23 hibernation doesn't work. When I try to hibernate the PC, everything seems to work as expected but the power switch led stays on. And when I try to wake up the PC, nothing happens. So, I've to keep the power switch pressed for few seconds (to really power off the PC) and then do a fresh start.

Version-Release number of selected component (if applicable):
4.3.4

How reproducible:
Always.

Steps to Reproduce:
1. From a running F23, press Alt to enable the hibernation
2.
3.

Actual results:
See description.

Expected results:
Hibernation should work as expected.

Additional info:
Comment 1 romu 2016-03-17 06:46 EDT
Created attachment 1137342 [details]
Screenshot when the computer is stuck at shutdown
Comment 2 romu 2016-03-17 06:48:14 EDT
Indeed, it's almost impossible to normally shutdown the computer. The shutdown process starts and ends stuck at the screen shown in the image here attached.
Comment 3 Laura Abbott 2016-09-23 15:50:30 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 4 romu 2016-09-27 03:29:01 EDT
Thanks to remind me this issue Laura. Since then, I've switched to F24 and hibernate works great. So I guess this is fixed.
Comment 5 Josh Boyer 2016-09-27 07:32:22 EDT
Thank you.

Note You need to log in before you can comment on or make changes to this bug.