Bug 1307037 - [libsrtp] wrong naming of shared library: libsrtp.so.1 is not a symbolic link
[libsrtp] wrong naming of shared library: libsrtp.so.1 is not a symbolic link
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libsrtp (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 1307270 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 09:22 EST by Joachim Frieben
Modified: 2016-02-16 14:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 09:45:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2016-02-12 09:22:15 EST
Description of problem:
In violation of the Fedora packaging guidelines, libsrtp contains a single shared library libsrtp.so.1 whereas normally this should be the name of a symbolic link to some shared library libsrtp.so.1.X.Y.
This bug causes recurrent complaints of ldconfig namely that libsrtp.so.1 is not a symbolic link.

Version-Release number of selected component (if applicable):
libsrtp-1.5.4-1.fc24

How reproducible:
Always

Steps to Reproduce:
1. Update to latest development build libsrtp-1.5.4-1.fc24.

Actual results:
The only entry in /usr/lib64/ belonging to package libsrtp-1.5.4-1.fc24 is libsrtp.so.1, and ldconfig complains that "libsrtp.so.1 is not a symbolic link".

Expected results:
There are two entries in /usr/lib64/ belonging to package libsrtp-1.5.4-1.fc24, namely libsrtp.so.1.X.Y and a symbolic link libsrtp.so.1.X.Y -> libsrtp.so.1.

Additional info:
None
Comment 1 Tom "spot" Callaway 2016-02-12 09:45:17 EST
It was too much to assume that upstream got this right... sorry about that and thanks for the quick bug filing. This is fixed in libsrtp-1.5.4-2.fc24.
Comment 2 Tom "spot" Callaway 2016-02-16 14:21:57 EST
*** Bug 1307270 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.