Bug 1307060 - Events list info doesn't match info provided by Tasks page
Events list info doesn't match info provided by Tasks page
Status: VERIFIED
Product: Red Hat Storage Console
Classification: Red Hat
Component: core (Show other bugs)
2
Unspecified Unspecified
unspecified Severity medium
: ---
: 2
Assigned To: Nishanth Thomas
Martin Kudlej
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 10:30 EST by Martin Bukatovic
Modified: 2016-08-08 09:24 EDT (History)
5 users (show)

See Also:
Fixed In Version: rhscon-ceph-0.0.23-1.el7scon.x86_64, rhscon-core-0.0.24-1.el7scon.x86_64, rhscon-ui-0.0.39-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the Events list with Hosts page (155.43 KB, image/png)
2016-02-12 10:30 EST, Martin Bukatovic
no flags Details

  None (edit)
Description Martin Bukatovic 2016-02-12 10:30:31 EST
Created attachment 1123536 [details]
screenshot of the Events list with Hosts page

Description of problem
======================

When I run Accept Node task for all 6 nodes available and a failure happens
during the process, I see mismatch in Events, Host state and Tasks.

This BZ is concerned about the fact that this mismatch happened and not about
the fact that accepting of some node(s) failed.

Version-Release number of selected component
============================================

# rpm -qa 'rhscon*'
rhscon-ceph-0.0.6-2.el7.x86_64
rhscon-ui-0.0.11-1.el7.noarch
rhscon-core-0.0.8-2.el7.x86_64

How reproducible
================

no data available so far, I may add stats later if needed

Steps to Reproduce
==================

1. Install skyring on server and prepare few hosts for cluster setup
2. Accept all nodes

I assume that Initialize Node task fails for one node here.

Actual results
==============

Tasks page reports that "Initialize Node" task for node1 is in Failed state.

On the other hand, there is a mismatch in reporting of this event in other
places:

There are 6 nodes in total (shown on the Hosts page), one of them is in
a failed state (small red icon with a cross).

There are 4 events in Events popup list (for node5, node2, node3 and node4),
all of the events report a success: "host is accesable now on"
(sic, BZ 1307053).

Expected results
================

When failure of "Initialize Node" taks happens for a single node, I would
expect to that:

 * 5 success events are shown in Events popup list
 * 1 failure event is shown in Events popup list

Note that this is just an example and other solutions are possible as well, but
information provided by usm should be consistent in every situation.
Comment 1 Martin Bukatovic 2016-02-12 10:33:02 EST
Note that this issue is not cause by accidental clearing of the Events popup list, because this is actually not possible right now - see BZ 1304292
Comment 2 Martin Bukatovic 2016-02-12 10:34:20 EST
Comment on attachment 1123536 [details]
screenshot of the Events list with Hosts page

(/me fixing description of the screenshot)
Comment 4 Nishanth Thomas 2016-03-10 04:30:56 EST
Additional details and a walk through of reproducer required
Comment 5 Nishanth Thomas 2016-05-05 05:30:55 EDT
Cam you provide the setup where I can reproduce this? Otherwise I am going to close this bug
Comment 6 Martin Bukatovic 2016-05-12 14:36:36 EDT
When I tried to reproduce this with the current builds (rhscon-ui-0.0.29-1.el7scon.noarch), I don't see a discrepancy between
Hosts and Tasks. There is a one failed host as well as a task.
Comment 9 Nishanth Thomas 2016-05-14 00:57:36 EDT
Since you confirmed that the reported issue is not seen in the latest builds, I assume that it got fixed and hence I am moving the bug to 'modified'
Comment 10 Martin Kudlej 2016-08-08 09:24:18 EDT
I haven't seen this issue for long time and it is bug reported before ceph-installer integration. --> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.