Bug 130717 - glibc 2.3.3-46 breaks building rpm
glibc 2.3.3-46 breaks building rpm
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-23 17:27 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 05:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-08-23 17:27:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The latest rawhide version of glibc produces a linking error when
compiling rpm. The build of rpm will not complete.

Version-Release number of selected component (if applicable):
2.3.3-46

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb rpm.spec

Actual Results:  /usr/lib/libdl.a(eval.o)(.text+0x1ec): In function
`_start':
: multiple definition of `_start'
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.3/../../../crt1.o(.text+0x0):
first defined here

Expected Results:  A message indicating where the rpm was written to.

Additional info:

Using the 45 release everything is OK. Something in the last set of
changes broke it.
Comment 1 Ulrich Drepper 2004-09-30 05:52:58 EDT
It definitely works for us, otherwise the code would not have been
released.  We do *not* provide support for other re-building the RPM.
 Solve the problems you created for yourself on your own.

Note You need to log in before you can comment on or make changes to this bug.