Bug 1307254 - [abrt] gqrx: QEventLoop::exec(): gqrx killed by SIGABRT
[abrt] gqrx: QEventLoop::exec(): gqrx killed by SIGABRT
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gqrx (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Olsthoorn
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:82bef1443667b98d5c49a12a6c4...
:
: 1363909 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-13 12:06 EST by Andy Lawrence
Modified: 2016-09-12 18:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.5.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 10:09:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.29 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: cgroup (200 bytes, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: core_backtrace (2.76 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: dso_list (16.34 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: environ (3.39 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: limits (1.29 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: maps (80.34 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: mountinfo (3.49 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: open_fds (1.32 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: proc_pid_status (1.01 KB, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details
File: var_log_messages (469 bytes, text/plain)
2016-02-13 12:06 EST, Andy Lawrence
no flags Details

  None (edit)
Description Andy Lawrence 2016-02-13 12:06:04 EST
Description of problem:
Attempting to enter Airspy as the IO device.

Version-Release number of selected component:
gqrx-2.3.2-13.fc23

Additional info:
reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        gqrx
crash_function: QEventLoop::exec
executable:     /usr/bin/gqrx
global_pid:     23981
kernel:         4.3.5-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #6 QEventLoop::exec at kernel/qeventloop.cpp:218
 #7 QCoreApplication::exec at kernel/qcoreapplication.cpp:1227
Comment 1 Andy Lawrence 2016-02-13 12:06:08 EST
Created attachment 1123834 [details]
File: backtrace
Comment 2 Andy Lawrence 2016-02-13 12:06:09 EST
Created attachment 1123835 [details]
File: cgroup
Comment 3 Andy Lawrence 2016-02-13 12:06:10 EST
Created attachment 1123836 [details]
File: core_backtrace
Comment 4 Andy Lawrence 2016-02-13 12:06:11 EST
Created attachment 1123837 [details]
File: dso_list
Comment 5 Andy Lawrence 2016-02-13 12:06:12 EST
Created attachment 1123838 [details]
File: environ
Comment 6 Andy Lawrence 2016-02-13 12:06:13 EST
Created attachment 1123839 [details]
File: limits
Comment 7 Andy Lawrence 2016-02-13 12:06:14 EST
Created attachment 1123840 [details]
File: maps
Comment 8 Andy Lawrence 2016-02-13 12:06:15 EST
Created attachment 1123841 [details]
File: mountinfo
Comment 9 Andy Lawrence 2016-02-13 12:06:15 EST
Created attachment 1123842 [details]
File: open_fds
Comment 10 Andy Lawrence 2016-02-13 12:06:16 EST
Created attachment 1123843 [details]
File: proc_pid_status
Comment 11 Andy Lawrence 2016-02-13 12:06:17 EST
Created attachment 1123844 [details]
File: var_log_messages
Comment 12 Dave Olsthoorn 2016-05-19 12:27:56 EDT
Is this still an issue with the new version?
Comment 13 gabe@codehaus.org 2016-08-03 18:26:54 EDT
*** Bug 1363909 has been marked as a duplicate of this bug. ***
Comment 14 Eric Christensen 2016-09-12 18:23:12 EDT
Similar problem has been detected:

This problem seemed to be caused by selecting my soundcard as the audio out path.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        gqrx
crash_function: QEventLoop::exec
executable:     /usr/bin/gqrx
global_pid:     8025
kernel:         4.7.2-101.fc23.x86_64
package:        gqrx-2.5.3-2.fc23
reason:         gqrx killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Note You need to log in before you can comment on or make changes to this bug.