Bug 1307320 - appmenu-qt5: FTBFS in rawhide
appmenu-qt5: FTBFS in rawhide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: appmenu-qt5 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
: Reopened
Depends On: 1311311
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:01 EST by Fedora Release Engineering
Modified: 2016-03-24 15:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 15:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (18.69 KB, text/plain)
2016-02-13 16:01 EST, Fedora Release Engineering
no flags Details
root.log (106.89 KB, text/plain)
2016-02-13 16:01 EST, Fedora Release Engineering
no flags Details
state.log (637 bytes, text/plain)
2016-02-13 16:01 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:01:20 EST
Your package appmenu-qt5 failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12806474

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:01:22 EST
Created attachment 1124030 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:01:23 EST
Created attachment 1124031 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:01:24 EST
Created attachment 1124032 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:33:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Ngo Than 2016-02-25 10:56:50 EST
it's fixed in qt5-qtbase-5.6.0-0.32.rc.fc24 or latest
Comment 6 Yaakov Selkowitz 2016-02-25 10:58:30 EST
(In reply to Ngo Than from comment #5)
> it's fixed in qt5-qtbase-5.6.0-0.32.rc.fc24 or latest

True but there hasn't been a build of that nor of appmenu-qt5 with it yet.
Comment 7 Yaakov Selkowitz 2016-02-25 14:40:49 EST
Now we have:

WARNING: Cannot open substitute for output '/usr/lib64/qt5/lib/cmake/Qt5Gui/Qt5Gui_AppMenuPlatformThemePlugin.cmake'
[snip]
error: File not found: /builddir/build/BUILDROOT/appmenu-qt5-0.r26-6.fc25.x86_64/usr/lib64/cmake/Qt5Gui/Qt5Gui_AppMenuPlatformThemePlugin.cmake

Note that that WARNING is happening during *make*; instead of generating the file under the builddir, it is creating it in the system root *during the build*.  Therefore, something is wrong in the mkspecs.

The last successful build of appmenu-qt5 was with 5.4.2, in which we see the following:

install -m 644 -p /builddir/build/BUILD/appmenu-qt5-0.r26/usr/lib64/cmake/Qt5Gui/Qt5Gui_AppMenuPlatformThemePlugin.cmake /builddir/build/BUILDROOT/appmenu-qt5-0.r26-5.fc23.x86_64/usr/lib64/cmake/Qt5Gui/

But this fails not only with 5.6-rc but also with 5.5.1 in a mock build.  Is this possibly the culprit?

https://github.com/qtproject/qtbase/commit/12ffa5853928c04cb8bcb487eafd3624d27a9b8b

Note cmake_target_file.output was different from the rest in that commit.
Comment 8 Yaakov Selkowitz 2016-02-25 20:17:58 EST
(In reply to Yaakov Selkowitz from comment #7)
> The last successful build of appmenu-qt5 was with 5.4.2, in which we see the
> following:
> 
> install -m 644 -p
> /builddir/build/BUILD/appmenu-qt5-0.r26/usr/lib64/cmake/Qt5Gui/
> Qt5Gui_AppMenuPlatformThemePlugin.cmake
> /builddir/build/BUILDROOT/appmenu-qt5-0.r26-5.fc23.x86_64/usr/lib64/cmake/
> Qt5Gui/

Now that I think about this further, this isn't right either, as the file is generated outside of the builddir (and only by luck still inside the source dir).  I'm guessing this code was written with Qt itself in mind; it still needs to be fixed for general consumption, but whatever changed between 5.4 and 5.6 clearly isn't correct either.
Comment 9 Mario Blättermann 2016-03-20 18:06:13 EDT
As the maintainer of the package, I would say it should be retired or at least orphaned. Some years ago it was needed in KDE 4 to display the global menu bar for Qt5 applications, with plasma-widget-menubar (bot no explicite runtime requirement of the latter). This applet hasn't been ported to Plasma 5 yet, and I'm afraid this will never happen. The latest upstream change was more then three years ago [1], so I assume appmenu-qt5 isn't worth to be further maintained in Fedora. However, it seems to be still active, the latest Ubuntu version is from 2015-11-30 [2].

[1] https://code.launchpad.net/plasma-widget-menubar
[2] https://code.launchpad.net/appmenu-qt5
Comment 10 Rex Dieter 2016-03-24 12:29:04 EDT
OK, reassigning to appmenu-qt5 for maintainer to retire (or to deal with it as they choose)
Comment 11 Fedora Admin XMLRPC Client 2016-03-24 15:47:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Mario Blättermann 2016-03-24 15:51:35 EDT
I've orphaned the package. No one of the currently supported Fedora versions ships KDE 4 anymore, which was the only purpose of this library. I will also notify the packaging list.

Note You need to log in before you can comment on or make changes to this bug.