Bug 1307372 - ceelog: FTBFS in rawhide
ceelog: FTBFS in rawhide
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ceelog (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:07 EST by Fedora Release Engineering
Modified: 2016-09-20 01:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-20 01:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (10.72 KB, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details
root.log (81.01 KB, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details
state.log (609 bytes, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:07:23 EST
Your package ceelog failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12809011

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:07:25 EST
Created attachment 1124186 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:07:26 EST
Created attachment 1124187 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:07:27 EST
Created attachment 1124188 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:35:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Yaakov Selkowitz 2016-02-24 21:33:22 EST
configure: error: Package requirements (json) were not met:
No package 'json' found

json-c-devel no longer provides the deprecated 'json' names since 0.12.  The PKG_CHECK_MODULES in configure{.ac,} need to be changed to 'json-c'.

Also filed upstream at https://fedorahosted.org/ceelog/ticket/1
Comment 6 Tomas Heinrich 2016-03-02 09:23:13 EST
I've fixed the pkg-config dependency and couple other issues (json-c headers' path, testsuite, locales extraction) and built the package for rawhide. If nothing else breaks, I'll submit updates for f23 and f24.

Note You need to log in before you can comment on or make changes to this bug.