Bug 1307394 - compat-guile18: FTBFS in rawhide
compat-guile18: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compat-guile18 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:09 EST by Fedora Release Engineering
Modified: 2016-02-17 09:41 EST (History)
3 users (show)

See Also:
Fixed In Version: compat-guile18-1.8.8-13.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 09:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (290.87 KB, text/plain)
2016-02-13 16:09 EST, Fedora Release Engineering
no flags Details
root.log (110.14 KB, text/plain)
2016-02-13 16:09 EST, Fedora Release Engineering
no flags Details
state.log (653 bytes, text/plain)
2016-02-13 16:09 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:09:39 EST
Your package compat-guile18 failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12809962

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:09:42 EST
Created attachment 1124252 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:09:44 EST
Created attachment 1124253 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:09:45 EST
Created attachment 1124254 [details]
state.log
Comment 4 Miroslav Lichvar 2016-02-17 09:41:40 EST
It looks like the problem is in scm_to_int64() (libguile/conv-integer.i.c) as it depends on -LLONG_MIN being less than zero, which is undefined behavior and it fails with the new gcc. Adding -fwrapv to the CFLAGS seems to fix it.

Interestingly, the code in guile-2.0.11 looks identical, but the test doesn't fail.

Note You need to log in before you can comment on or make changes to this bug.