Bug 130787 - Propose change of bug id data format submitted to RHN using the Errata System.
Propose change of bug id data format submitted to RHN using the Errata System.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On:
Blocks: 123188
  Show dependency treegraph
 
Reported: 2004-08-24 14:16 EDT by David Lawrence
Modified: 2007-04-18 13:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 12:30:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2004-08-24 14:16:11 EDT
Description of problem:
I would like to change the format of the data structure containing the
bug ids fixes that is stored in the XML of the errata report.
Currently it consists of a simple list of text strings that contain
the bug id and summary. Since we also need to track which bug ids are
private/public I would like to change it to be a list of hashes
(dictionaries). Like:

@idsfixedlist = [
                  { 
                     id => 3454,
                     summary => "Some Bad Bug Summary",
                     private => 0,
                  },
                  {
                     id => 123453,
                     summary => "Another possibly crappy bug",
                     private => 1,
                  }
                ];

This is perl-speak but the idea should be apparent. Let me know if
this possible and also timeframe.
Comment 1 Mihai Ibanescu 2004-10-07 00:38:39 EDT
Not sure I can squeeze this in the 360 timeframe (that would be
mid-november).
Comment 2 David Lawrence 2004-10-19 17:23:20 EDT
This has now been changed.  I am still passing the old idsfixedlist as
usual, but I now have a new key called "bugs" that is a list of
hashes. Such as:

@bugs = [
         { 
           id => 3454,
           summary => "Some Bad Bug Summary",
           private => 0,
         },
         {
           id => 123453,
           summary => "Another possibly crappy bug",
           private => 1,
         }
        ];

Please do not display bug reports that are marked private on the
external facing pages if you are displaying bugs fixed.

Let me know if this is ok for now.
Comment 3 Mihai Ibanescu 2004-10-20 18:42:39 EDT
Looks good. Code is in.
Dave, would you mind QA-ing this once we hit QA?
Comment 4 Todd Warner 2004-10-21 12:18:31 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 5 David Lawrence 2004-11-01 16:39:51 EST
Seems ok for this end. Several errata have been pushed to webqa with
no error conditions reported and the bugs also seem to be displayed
properly in the rhn errata documents. Moveing to PROD_READY.
Comment 6 Todd Warner 2005-03-22 12:30:45 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.