Bug 130788 - kernel-2.6.8-1.521 breaks wine
kernel-2.6.8-1.521 breaks wine
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-08-24 14:28 EDT by Richard Plana
Modified: 2015-01-04 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 00:54:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard Plana 2004-08-24 14:28:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
Using the kernel release above would break wine with an error of:

wine: failed to create the process heap

None of the previous FC2 release kernels exhibited this behavior.
Neither the trick of using "setarch i386" nor "echo 0 >
/proc/sys/kernel/exec-shield" (documented elsewhere) made a difference.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Upgrade to kernel-2.6.8-1.521
2. Execute "wine" or any wine-executable

Downgrade to kernel-2.6.7-1.494.2.2 and the problem goes away.

Additional info:
Comment 1 Richard Plana 2004-08-24 14:30:00 EDT
Forgot to mention ... using wine-0.20040505-1.rhfc2.nr
Comment 2 Need Real Name 2004-08-25 05:44:15 EDT
I am having a similar problem with an old Loki game civctp. Worked
fine up to kernel-2.6.7-1.494.2.2. Stopped working with

I tried  setarch i386 and echo 1 > /proc/sys/vm/legacy_va_layout
Comment 3 Dave Jones 2004-11-27 15:24:16 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 4 Need Real Name 2004-11-28 01:12:12 EST
Yep, I have update to fedora core 3 and civctp still doesn't work
Comment 5 Warren Togami 2004-11-28 03:33:10 EST
Is this an issue with vanilla upstream latest kernel, using the same
/boot/config-* as the Fedora kernel?

Ultimately this isn't our problem and it is wine that needs to be
fixed, but it would be good to know if any configuration option in
particular triggers this failure in wine.

Have you tried WineX (Cedega)?
Comment 6 Dave Jones 2005-01-17 03:37:36 EST
how about the latest 2.6.10 update errata kernels ?
Comment 7 Richard Plana 2005-01-21 13:13:50 EST
Upgraded my machines to FC3 so I can't test on the FC2 platform. However, on FC3
with kernel-2.6.10-1.741_FC3 and wine-20041201-1fc3winehq, worksforme.
Comment 8 Dave Jones 2005-04-16 00:54:56 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.