Bug 130790 - Erratta: RHBA-2004:300 Breaks 'sar -d'
Erratta: RHBA-2004:300 Breaks 'sar -d'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: sysstat (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Charlie Bennett
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-24 15:01 EDT by Bruce Garlock
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 16:15:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Garlock 2004-08-24 15:01:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.2)
Gecko/20030624 Netscape/7.1 (ax; CDonDemand-Dom)

Description of problem:
Our production system was updated on Thursday, August 19th.  This is
the last time I was able to use the -d switch with sar.  I now get
this error:

[root@linux root]# sar -d
Requested activities not available in file




Version-Release number of selected component (if applicable):
sysstat-4.0.1-15.2.1as

How reproducible:
Always

Steps to Reproduce:
1. sar -d
2.
3.
    

Actual Results:  Error:

Requested activities not available in file


Expected Results:  Should produce output similar to this:

[root@linux sa]# sar -d -f sa19
Linux 2.4.9-e.48 (linux.server)         08/19/2004

12:00:00 AM       DEV       tps    blks/s
12:10:01 AM    dev8-0     11.70    290.86
12:20:01 AM    dev8-0    194.83  10943.04
12:30:00 AM    dev8-0    241.84  12311.72


.....
.....
etc...

Additional info:

I am considering installing the old version of sysstat, since I am
currently trying to do performance tuning, and need this output.
Comment 2 Charlie Bennett 2004-09-08 13:39:58 EDT
Hi - can you check out the (unsupported) sysstat-5.0.5 in
http://people.redhat.com/sysstat and verify that it addresses this
problem.  If so, you are best to roll back your sysstat until this new
one is released in a supported update.

Thanks!
Comment 3 Bruce Garlock 2004-09-08 13:46:18 EDT
I get a 404 error with that link.  Can you please check your spelling?

Thanks,

Bruce
Comment 4 Bruce Garlock 2004-09-08 13:59:38 EDT
I figured out, by guessing, that the link s/b:

http://people.redhat.com/ccb/sysstat

Good guess for me!!

I will give it a whirl, and let you know..


Thanks,

Bruce
Comment 5 Bruce Garlock 2004-09-08 14:04:05 EDT
Yes, this new version works fine now!  I will now backport to the
older, supported version, until an Errata is released.  Any idea when
an errata will be released for sysstat?

Thanks,

Bruce
Comment 6 Bruce Garlock 2004-09-08 14:11:02 EDT
FYI:
When I backport to the sysstat-4.0.1-15.2.1as the log file in
/var/sa/sa08 (in this case) is unreadable in the older version.  i.e.
The sysstat-5.0.5-3.i386 version produces a sa file that is unreadable
by sysstat-4.0.1-15.2.1as.  My work around/fix was to delete the file,
and run the cron entry manually to create a new file that
sysstat-4.0.1-15.2.1as can read.

- Bruce
Comment 7 Charlie Bennett 2004-09-29 11:17:35 EDT
Release planned for next udpate. (U6)
Tentative Erratum RHBA-2004:503
Comment 8 John Flanagan 2004-12-13 16:15:21 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-503.html

Note You need to log in before you can comment on or make changes to this bug.