Bug 1308001 - rubygem-acts_as_list: FTBFS in rawhide
rubygem-acts_as_list: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-acts_as_list (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:16 EST by Fedora Release Engineering
Modified: 2016-04-07 08:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: rubygem-acts_as_list-0.7.2-1.fc25 rubygem-acts_as_list-0.7.2-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 08:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (158.36 KB, text/plain)
2016-02-13 17:16 EST, Fedora Release Engineering
no flags Details
root.log (84.86 KB, text/plain)
2016-02-13 17:16 EST, Fedora Release Engineering
no flags Details
state.log (673 bytes, text/plain)
2016-02-13 17:16 EST, Fedora Release Engineering
no flags Details
Update version to 0.7.2 to test suite for Ruby 2.3 compatibility. (1.89 KB, patch)
2016-03-23 13:59 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:16:40 EST
Your package rubygem-acts_as_list failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12865576

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:16:42 EST
Created attachment 1126063 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:16:44 EST
Created attachment 1126064 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:16:45 EST
Created attachment 1126065 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:06:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-03-23 13:59 EDT
Created attachment 1139676 [details]
Update version to 0.7.2 to test suite for Ruby 2.3 compatibility.

Current version 0.4.0 has several issues to pass the test.

So, I updated gem version from 0.4.0 to latest version 0.7.2.
Then all the test was passed.

Also I checked any package does not use this package.

# dnf repoquery --whatrequires 'rubygem(acts_as_list)'

I will attach the patch file.
Comment 6 Vít Ondruch 2016-03-23 14:10:36 EDT
(In reply to Jun Aruga from comment #5)
> # dnf repoquery --whatrequires 'rubygem(acts_as_list)'

This is not enough. You should check:

1) Runtime dependencies:
dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(acts_as_list)'
dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-acts_as_list'

2) As well as development dependencies:
dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(acts_as_list)'
dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-acts_as_list'

Also, these queries checks against Rawhide, where this fix will go.
Comment 7 Jun Aruga 2016-03-24 08:59:47 EDT
Vit, thanks for the message.

$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(acts_as_list)'
  => no result.

$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-acts_as_list'
rubygem-acts_as_list-doc-0:0.4.0-1.fc22.noarch

$ sudo dnf install fedora-repos-rawhide
Error: Failed to synchronize cache for repo 'rawhide-source' from 'https://mirrors.fedoraproject.org/metalink?repo=rawhide-source&arch=x86_64': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Accessed this URL https://mirrors.fedoraproject.org/metalink?repo=rawhide-source&arch=x86_64 by Firefox. Downloaded metalink file for that.

$ cat ~/Downloads/metalink
<?xml version="1.0" encoding="utf-8"?>
      <resources maxconnections="1">
        <url protocol="ftp" type="ftp" location="DE" preference="100" >ftp://ftp.halifax.rwth-aachen.de/fedora/linux/development/rawhide/source/SRPMS/repodata/repomd.xml</url>
        <url protocol="http" type="http" location="DE" preference="100" >http://ftp.halifax.rwth-aachen.de/fedora/linux/development/rawhide/source/SRPMS/repodata/repomd.xml</url>
...
        <url protocol="http" type="http" location="ES" preference="96" >http://mirror.uv.es/mirror/fedora/linux/development/rawhide/source/SRPMS/repodata/repomd.xml</url>
      </resources>
    </file>
  </files>
</metalink>

$ wget ftp://ftp.halifax.rwth-aachen.de/fedora/linux/development/rawhide/source/SRPMS/repodata/repomd.xml
...
No such file ‘repomd.xml’.

$ wget http://ftp.halifax.rwth-aachen.de/fedora/linux/development/rawhide/source/SRPMS/repodata/repomd.xml
...
2016-03-24 13:57:33 ERROR 404: Not Found.

Something wrong for above servers.

So, I will try above commands after tomorrow again.
Comment 8 Jun Aruga 2016-03-29 04:49:13 EDT
1) Runtime dependencies:
$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(acts_as_list)'
  => no result.
$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-acts_as_list'
rubygem-acts_as_list-doc-0:0.4.0-1.fc22.noarch


2) As well as development dependencies:
$ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(acts_as_list)'
  => no result.
$ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-acts_as_list'
  => no result.

As a conclusion, below package is using acts-as_list.
- rubygem-acts_as_list-doc-0:0.4.0-1.fc22.noarch


Actually about 2), I changed rawhide-source's mirror server to an active server, and it works.

# vi /etc/yum.repos.d/fedora-rawhide.repo
...
[rawhide-source]
...
# It does not work.
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/source/SRPMS/
# It works
baseurl=http://ftp.uninett.no/linux/fedora/development/rawhide/source/SRPMS/
* It does not work.
#metalink=https://mirrors.fedoraproject.org/metalink?repo=rawhide-source&arch=$basearch
Comment 9 Jun Aruga 2016-03-31 09:35:01 EDT
> Actually about 2), I changed rawhide-source's mirror server to an active server, and it works.

I asked infra team about above "mirror server of dnf repoquery" issue, and I found that it can be sometimes happened in the date of alpha release, or rawhide not composing. 

See below URL for detail.
https://lists.fedoraproject.org/archives/list/infrastructure@lists.fedoraproject.org/thread/FU3BLCY7RWPGGOAMXPL3DG5QISFUZXLD/
Comment 10 Upstream Release Monitoring 2016-04-01 09:25:32 EDT
jaruga's rubygem-acts_as_list-0.7.2-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=750360
Comment 11 Fedora Update System 2016-04-01 09:45:21 EDT
rubygem-acts_as_list-0.7.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-330e98b8fc
Comment 12 Fedora Update System 2016-04-02 01:24:36 EDT
rubygem-acts_as_list-0.7.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-330e98b8fc
Comment 13 Fedora Update System 2016-04-07 08:06:43 EDT
rubygem-acts_as_list-0.7.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.