Bug 130823 - Audit does not generate records for the pread/pwrite system calls
Audit does not generate records for the pread/pwrite system calls
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
: FutureFeature
: 130930 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-24 18:02 EDT by Peter Martuccelli
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:55:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Martuccelli 2004-08-24 18:02:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
Audit needs to generate audit records for the pread/pwrite system
calls, this is a user request not a requirement for EAL certification.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run a program which calls pread/pwrite
2.a complete audit record is not generated
3.
    

Actual Results:  audit record with no argument data is generated

Expected Results:  a compete audit record

Additional info:
Comment 1 Peter Martuccelli 2004-08-24 18:06:53 EDT
Request from customer through service.  This is not required for EAL3
certification but will be addressed per customers request for audit
support of the pread/pwrite system calls.

Comment 2 Ernie Petrides 2004-08-25 20:13:00 EDT
*** Bug 130929 has been marked as a duplicate of this bug. ***
Comment 3 Ernie Petrides 2004-08-25 20:13:58 EDT
*** Bug 130930 has been marked as a duplicate of this bug. ***
Comment 4 Ernie Petrides 2004-09-11 01:18:05 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.5.EL).
Comment 5 John Flanagan 2004-12-20 15:55:59 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.