Bug 1308244 - wxGTK3: FTBFS in rawhide
wxGTK3: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wxGTK3 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Talbert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:42 EST by Fedora Release Engineering
Modified: 2016-02-22 22:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 22:27:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (342.67 KB, text/plain)
2016-02-13 17:42 EST, Fedora Release Engineering
no flags Details
root.log (119.12 KB, text/plain)
2016-02-13 17:42 EST, Fedora Release Engineering
no flags Details
state.log (621 bytes, text/plain)
2016-02-13 17:42 EST, Fedora Release Engineering
no flags Details
Patch to fix FTBFS (913 bytes, patch)
2016-02-20 13:12 EST, Scott Talbert
no flags Details | Diff
Work around removed cppunit-config (776 bytes, patch)
2016-02-20 23:18 EST, Scott Talbert
no flags Details | Diff
Fix issue with strings.cpp and GCC6 (2.08 KB, patch)
2016-02-20 23:19 EST, Scott Talbert
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:42:05 EST
Your package wxGTK3 failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12878354

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:42:08 EST
Created attachment 1126800 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:42:09 EST
Created attachment 1126801 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:42:10 EST
Created attachment 1126802 [details]
state.log
Comment 4 Yaakov Selkowitz 2016-02-19 12:59:05 EST
Looks like missing #include <math.h> in src/stc/scintilla/src/Editor.cxx.
Comment 5 Scott Talbert 2016-02-20 13:12 EST
Created attachment 1128839 [details]
Patch to fix FTBFS

Here's a patch to fix this issue (as upstream did it).  After this is fixed, there is another problem though.  The tests are failing because /usr/bin/cppunit-config was removed in Rawhide.
Comment 6 Scott Talbert 2016-02-20 23:18 EST
Created attachment 1128910 [details]
Work around removed cppunit-config

Ok, here's a spec workaround for the removed cppunit-config.  After that is fixed, there was another problem with one of the tests.  It already had a patch upstream, but I'll attach it.
Comment 7 Scott Talbert 2016-02-20 23:19 EST
Created attachment 1128911 [details]
Fix issue with strings.cpp and GCC6
Comment 8 Scott Talbert 2016-02-20 23:20:39 EST
Also, Jeremy would you like a co-maintainer?  :-)
Comment 9 Jeremy Newton 2016-02-20 23:27:48 EST
Sure, I've been meaning to look into this but I've had a busy week.
Does all these packages fix the FTBFS?
Comment 10 Jeremy Newton 2016-02-20 23:30:07 EST
Sorry I meant to say, do all these patches fix the FTBFS?
Comment 11 Scott Talbert 2016-02-20 23:34:59 EST
Yes, it builds with all 3 patches.
Comment 12 Jeremy Newton 2016-02-21 00:01:05 EST
What's your FAS username?
Comment 13 Scott Talbert 2016-02-21 00:30:42 EST
swt2c
Comment 14 Jeremy Newton 2016-02-22 17:04:25 EST
Sorry for the delay, I just approved commit access.

I just made a commit to fix #1294712, so please fix rawhide based on that.

Thanks for your help!
Comment 15 Upstream Release Monitoring 2016-02-22 22:25:33 EST
swt2c's wxGTK3-3.0.2-15.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=738160

Note You need to log in before you can comment on or make changes to this bug.