Bug 1308266 - zidrav: FTBFS in rawhide
zidrav: FTBFS in rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: zidrav (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:44 EST by Fedora Release Engineering
Modified: 2016-02-15 08:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 08:49:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (37.46 KB, text/plain)
2016-02-13 17:44 EST, Fedora Release Engineering
no flags Details
root.log (79.84 KB, text/plain)
2016-02-13 17:44 EST, Fedora Release Engineering
no flags Details
state.log (621 bytes, text/plain)
2016-02-13 17:44 EST, Fedora Release Engineering
no flags Details
proposed patch (3.01 KB, patch)
2016-02-15 00:35 EST, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:44:15 EST
Your package zidrav failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12880640

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:44:17 EST
Created attachment 1126866 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:44:18 EST
Created attachment 1126867 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:44:19 EST
Created attachment 1126868 [details]
state.log
Comment 4 Ralf Corsepius 2016-02-15 00:35 EST
Created attachment 1127164 [details]
proposed patch

The cause of this FTBFS is narrowing issues on i386 and arm.

The patch in the attachment should address these.
Scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=12990374

Unless somebody objects, I will apply these changes throughout the next couple of days.
Comment 5 Dominik 'Rathann' Mierzejewski 2016-02-15 03:34:44 EST
Thanks for looking into this, Ralf. Your proposed patch doesn't contain the zidrav-gcc60.patch and I'd like to see it before you commit. Please add -b .gcc60 to %patch macro call. Other than that, I'm fine with your change (assuming the missing patch is ok).
Comment 6 Ralf Corsepius 2016-02-15 03:55:06 EST
(In reply to Dominik 'Rathann' Mierzejewski from comment #5)
> Thanks for looking into this, Ralf. Your proposed patch doesn't contain the
> zidrav-gcc60.patch and I'd like to see it before you commit.
?!? It's there: https://bugzilla.redhat.com/attachment.cgi?id=1127164

Cut'n'paste from the URL above:

+diff -Naur zidrav4unix-1.2.0.orig/core.h zidrav4unix-1.2.0/core.h
+--- zidrav4unix-1.2.0.orig/core.h	2016-02-15 05:21:09.143118636 +0100
++++ zidrav4unix-1.2.0/core.h	2016-02-15 05:22:02.503690038 +0100
+@@ -48,7 +48,7 @@
+ #define QSV		KSigver( ZQ, QVER )
+ 
+ 
+-const long crc_table[256] = {		// it's just easier this way, alright? It's one K of data, I'm allowed a global if I want one
++const unsigned long crc_table[256] = {		// it's just easier this way, alright? It's one K of data, I'm allowed a global if I want one
+   0x00000000L, 0x77073096L, 0xee0e612cL, 0x990951baL, 0x076dc419L,
+   0x706af48fL, 0xe963a535L, 0x9e6495a3L, 0x0edb8832L, 0x79dcb8a4L,
+   0xe0d5e91eL, 0x97d2d988L, 0x09b64c2bL, 0x7eb17cbdL, 0xe7b82d07L,

This patch is a "git format-patch"-generated patch against git/master.
Just download this file and "git am <file>" in a clone of git/master.
Comment 7 Dominik 'Rathann' Mierzejewski 2016-02-15 05:02:02 EST
My apologies, I can see it now. It wasn't showing up completely in the 'diff' view of bugzilla (https://bugzilla.redhat.com/attachment.cgi?id=1127164&action=diff). Feel free to apply. Thank you.
Comment 8 Ralf Corsepius 2016-02-15 08:49:40 EST
Patch applied, package rebuilt for rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=12992951

Note You need to log in before you can comment on or make changes to this bug.