This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1308418 - VDSMD service should be disabled by default after installation on RHEL7
VDSMD service should be disabled by default after installation on RHEL7
Status: CLOSED WONTFIX
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.18
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: Yaniv Bronhaim
Petr Kubica
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 02:12 EST by Sahina Bose
Modified: 2016-03-17 03:13 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305201
Environment:
Last Closed: 2016-03-17 03:13:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sabose: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
pstehlik: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Sahina Bose 2016-02-15 02:12:00 EST
Description of problem:

vdsm service on RHEL 7 is enabled by default on installation. When the server is rebooted, there are errors related to being unable to start the service as vdsm has not been configured. (The node has not been added to oVirt)

Note: vdsm on RHEL 6 is disabled by default and works as expected
Comment 3 Yaniv Bronhaim 2016-02-24 08:57:05 EST
we currently enable vdsmd.service supervdsmd.service vdsm-network.service and mom-vdsm.service as part of vdsm rpm installation.

host-deploy enables vdsmd and supervdsmd.

and as far as I see - we do chkconfig on for vdsmd and supervdsmd over el6.. what vdsm versions do you use? the behavior should be the same
Comment 4 Oved Ourfali 2016-03-08 03:33:38 EST
Sahina?
Comment 5 Sahina Bose 2016-03-16 06:12:42 EDT
vdsm version was 4.16.30
Comment 7 Sahina Bose 2016-03-16 06:17:31 EDT
The behaviour is consistent upstream for EL6 and EL7 , sorry about the confusion.

You can close this if this is the intended behaviour of vdsm/supervdsm.
Comment 8 Yaniv Bronhaim 2016-03-17 03:13:03 EDT
Yes, this is the intend behavior in both distributions and I don't see any problem with that ... unless someone has good reason for keeping it disabled after yum installation, please re-open.

Note You need to log in before you can comment on or make changes to this bug.