Bug 1308450 - Allow parent processes to terminate graciously after calling shutdown -r now/reboot/init 6
Allow parent processes to terminate graciously after calling shutdown -r now/...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
:
: 1274433 (view as bug list)
Depends On:
Blocks: 1289485
  Show dependency treegraph
 
Reported: 2016-02-15 04:26 EST by Tomáš Kašpárek
Modified: 2016-02-15 08:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 07:47:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Kašpárek 2016-02-15 04:26:07 EST
Description of problem:
When calling shutdown -r/reboot/init 6 parent process should be allowed to terminate graciously like on RHEL6 where systemd is not used.

Version-Release number of selected component (if applicable):
systemd-219-19.el7.x86_64

How reproducible:
always, deterministic

Steps to Reproduce:
1. execute bash script with following content (as root):
#!/bin/bash

shutdown -r now
touch /root/test

2. ls /root/test
3. file /root/test does not exist

4. shutdown -r now can be replaced with either reboot or init 6, behavior is not changed

Actual results:
File /root/test does not exist as parent process is not allowed to terminate graciously.

Expected results:
File /root/test should exist like it does when executed on RHEL 6.7 machine (it gets created on RHEL 6.7 in all 3 cases).

Additional info:
This behavior is root cause of following bug: https://bugzilla.redhat.com/show_bug.cgi?id=1260527
Comment 1 Lukáš Nykrýn 2016-02-15 07:47:18 EST
Well, your reproducer should not work anywhere because:

1) Init will send you sigterm immediately which will kill your script.
2) Termination of login process will end up with sighup, which will kill your script.

If you try to block those signals:
[root@localhost ~]# cat test.sh 
#!/bin/bash
logger "XXXXX-my pid: $$"
trap "echo nope" SIGTERM SIGINT
reboot &
sleep 2
echo whoohooo > /root/out
[root@localhost ~]# nohup ./test.sh

The /root/out will be created. I guess it worked for you on rhel6 only because the shutdown was pretty slow there.
Comment 2 Lukáš Nykrýn 2016-02-15 08:08:56 EST
*** Bug 1274433 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.