Bug 1308472 - Local disk should display as "/dev/sd*" but not "/dev/mapper/xxx"
Local disk should display as "/dev/sd*" but not "/dev/mapper/xxx"
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.2
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Fabian Deutsch
Wei Wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 05:06 EST by Wei Wang
Modified: 2016-02-23 03:12 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 03:12:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/*.* (434.29 KB, application/x-gzip)
2016-02-15 05:06 EST, Wei Wang
no flags Details
local-disk (392.34 KB, image/png)
2016-02-15 05:07 EST, Wei Wang
no flags Details
sosreport (5.34 MB, application/x-xz)
2016-02-17 21:38 EST, Wei Wang
no flags Details
/etc (7.01 MB, application/x-gzip)
2016-02-17 21:43 EST, Wei Wang
no flags Details
/config (740.09 KB, application/x-gzip)
2016-02-17 21:47 EST, Wei Wang
no flags Details

  None (edit)
Description Wei Wang 2016-02-15 05:06:13 EST
Created attachment 1127221 [details]
/var/log/*.*

Description of problem:
Local disk should display as "/dev/sd*" but not  "/dev/mapper/xxx"

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20160212.0
ovirt-node-3.6.1-6.0.el7ev.noarch

How reproducible:
100%


Steps to Reproduce:
1. TUI clean installed rhevh on local machine.
2. Enter "select the disk" page
3. Check device name in the device list


Actual results:
Device name display as "/dev/mapper/xxx"


Expected results:
Device name should display as "/dev/sd*"

Additional info:
No such issue in 7.2_3.5 build
Comment 1 Wei Wang 2016-02-15 05:07 EST
Created attachment 1127222 [details]
local-disk
Comment 2 Fabian Deutsch 2016-02-16 06:49:03 EST
What kind of machine is used?

What is the output of multipath -ll? (sosreport helps as well)
Comment 3 Wei Wang 2016-02-16 21:55:00 EST
(In reply to Fabian Deutsch from comment #2)
> What kind of machine is used?
> 
Machine:Dell-760/790 
Hard disk: SAMSUNG_HD322GM
CPU: Intel(R) Core(TM)2 x86_64

> What is the output of multipath -ll? (sosreport helps as well)
multipath -ll
SAMSUNG_HD322GM_S2PAJ90B519911 dm-0 ATA ,SAMSUNG HD322GM
size=298G features='0' hwhandler='0' wp=rw
`-+- policy='service-time 0' prio=1 status=active
`- 2:0:0:0 sda 8:0 active ready running
Comment 4 Fabian Deutsch 2016-02-17 03:26:50 EST
Please also provide the sosreport and all of /etc and /config
Comment 5 Wei Wang 2016-02-17 21:38 EST
Created attachment 1128126 [details]
sosreport
Comment 6 Wei Wang 2016-02-17 21:43 EST
Created attachment 1128127 [details]
/etc
Comment 7 Wei Wang 2016-02-17 21:47 EST
Created attachment 1128128 [details]
/config
Comment 8 Fabian Deutsch 2016-02-22 04:37:40 EST
This behavior is okay in RHEV 3.6.

In RHEV 3.6 vdsm's multipath config is used right from the beginning, and vdsm is configuring to always use mapper names - even for single path devices.

For new 3.6 installations this should not be a problem.

What about upgrades? On a machine where in RHEV 3.5 /dev/sd* was used, does the upgrade work to RHEV-H 3.6?
Comment 9 Wei Wang 2016-02-22 04:55:34 EST
Since during upgrades we cannot see the select page, so do we have another way to get the info which we want?
Comment 10 Fabian Deutsch 2016-02-22 08:42:26 EST
The question is if upgrades are working, it is correct that you don't see the storage page.
Comment 11 Wei Wang 2016-02-23 01:20:20 EST
Upgrades is successful from rhev-hypervisor7-7.2-20151129.1 to rhev-hypervisor7-7.2-20160212.0
Comment 12 Fabian Deutsch 2016-02-23 03:12:31 EST
This is good news.

For now I don't see a risk in this change of devices witha  single path also appearing as mapper devices.

The only visual change is in the TUI: In 3.5 there was /dev/[hs]d*, in 3.6 there will be /dev/mapper/..
But this is only visual and does not have a functional impact.

Note You need to log in before you can comment on or make changes to this bug.