Bug 130848 - After running latest 'yum update' dns stops resolving
Summary: After running latest 'yum update' dns stops resolving
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-25 08:14 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: initscripts-7.67
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 13:22:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the offending yum update (23.08 KB, text/plain)
2004-08-25 08:16 UTC, Need Real Name
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:566 normal SHIPPED_LIVE Updated dhcp and dhclient packages 2005-05-26 04:00:00 UTC

Description Need Real Name 2004-08-25 08:14:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
I have installed Fedora Core 3 test 1 on an athlon server machine
today, on my uni campus. It installed ok, detected all network
hardware and recieved both ipv6 and ipv4 address by dhcp, and I was
browsing using mozilla normally. 

I then changed the yum.conf file to pull from the local yum repository
mirror on campus. Then, I ran 'yum update' as usual and updated all
package to the latest version, and no errors or problems. The mirror
people say they sync their repository very early every morning. I
rebooted, again no errors. However dns addresses fail to resolve, such
as I type 'ping google.com' and it replies

ping: unknown host google.com

However the system and network connection function perfectly, I am
logged in over ssh to it right now.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install fedora core 3 test 1
2. run 'yum update', say 'y'
3. reboot
4. 'ping google.com'
    

Actual Results:  ping: unknown host google.com

worked previously before 'yum update'

Expected Results:  dns resolved

Additional info:

I will post /var/log/yum.log in a sec

Comment 1 Need Real Name 2004-08-25 08:16:04 UTC
Created attachment 103052 [details]
the offending yum update

please ask if more info is needed, I can post more.

Comment 2 Harald Hoyer 2004-08-25 08:48:27 UTC
this is more likely dhcp

Comment 3 Jason Vas Dias 2004-08-25 13:22:10 UTC
There was a problem with initscripts-7.66 that caused this -
be sure you have initscripts-7.67 .

Comment 4 John Flanagan 2004-12-21 19:41:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html



Note You need to log in before you can comment on or make changes to this bug.