Bug 1308490 - Installer: unneeded installation path check
Installer: unneeded installation path check
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.3.0
Assigned To: Thomas Hauser
Jan Stastny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 06:31 EST by Jan Stastny
Modified: 2016-08-24 07:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:35:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stastny 2016-02-15 06:31:56 EST
Description of problem:
DV installer should be installed over an existing EAP instance. Thus, there is no need for a warning dialog, that the path specified by user already exists.

Version-Release number of selected component (if applicable):
DV 6.3.0.DR3-redhat-1
Comment 1 Debi Rieden 2016-05-23 09:42:55 EDT
We discussed this at the bug triage:

If there is an EAP installed, and user chooses to install into this directory, 
no new EAP will be installed.  The existing EAP instance will be used.

Kim: Would like to have a message issued to user to indicate this.
Comment 2 Van Halbert 2016-05-23 09:49:55 EDT
Mansi / Tom:

Now that DV will be bundling EAP and DV, and the installation will need to support both, installing EAP/DV and installing DV into an existing EAP instance, this BZ is no longer applicable.  However, since this was changed to MODIFIED, it implies there were changes.  Unfortunately, those changes should be undone and returned to the previous behavior of presenting a warning dialog when the EAP instance already exist.
Comment 3 Mansi Vaghela 2016-05-25 13:46:15 EDT
The changes have been reverted

Note You need to log in before you can comment on or make changes to this bug.