Bug 1308565 - org.slf4j and org.slf4j.impl modules have circular dependency on each other
org.slf4j and org.slf4j.impl modules have circular dependency on each other
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.4.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: jboss-set
Nikoleta Ziakova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 09:07 EST by Pavel Jelinek
Modified: 2016-03-17 07:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 07:29:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEAP-3411 Major Closed org.slf4j and org.slf4j.impl modules have circular dependencyon each other 2017-03-10 08:09 EST

  None (edit)
Description Pavel Jelinek 2016-02-15 09:07:10 EST
This is caused by API classes from org.slf4j which depend on implementation classes from org.slf4j.impl module.
Comment 1 JBoss JIRA Server 2016-03-17 07:27:01 EDT
Romain Pelisse <belaran@redhat.com> updated the status of jira JBEAP-3411 to Closed
Comment 2 Romain Pelisse 2016-03-17 07:29:32 EDT
As discussed on JBEAP-3411, this circular dependency is required. There is no plan to fix upstream (at least not quite soon) and thus no ground to backport it and fix it into 6.4.x. 

Therefore I'm closing this issue (but of course if you feel I'm wrong to do so, please reopen it).

Note You need to log in before you can comment on or make changes to this bug.