This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1308679 - ValueError: User nobody already exists
ValueError: User nobody already exists
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:de80080f7230554d969a5e80b6d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 12:45 EST by Izzedine
Modified: 2016-04-23 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-24.13.4-1 anaconda-24.13.4-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-23 19:45:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.23 MB, text/plain)
2016-02-15 12:46 EST, Izzedine
no flags Details
File: anaconda.log (24.70 KB, text/plain)
2016-02-15 12:47 EST, Izzedine
no flags Details
File: environ (599 bytes, text/plain)
2016-02-15 12:47 EST, Izzedine
no flags Details
File: journalctl (579.67 KB, text/plain)
2016-02-15 12:48 EST, Izzedine
no flags Details
File: lsblk_output (2.88 KB, text/plain)
2016-02-15 12:48 EST, Izzedine
no flags Details
File: nmcli_dev_list (1.53 KB, text/plain)
2016-02-15 12:48 EST, Izzedine
no flags Details
File: os_info (451 bytes, text/plain)
2016-02-15 12:48 EST, Izzedine
no flags Details
File: program.log (151.42 KB, text/plain)
2016-02-15 12:48 EST, Izzedine
no flags Details
File: storage.log (387.33 KB, text/plain)
2016-02-15 12:49 EST, Izzedine
no flags Details
File: ifcfg.log (2.74 KB, text/plain)
2016-02-15 12:49 EST, Izzedine
no flags Details
File: packaging.log (131 bytes, text/plain)
2016-02-15 12:49 EST, Izzedine
no flags Details

  None (edit)
Description Izzedine 2016-02-15 12:45:26 EST
Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.i686

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/pyanaconda/users.py", line 263, in createUser
    raise ValueError("User %s already exists" % user_name)
  File "/usr/lib/python3.4/site-packages/pyanaconda/kickstart.py", line 1742, in execute
    if not users.createUser(usr.name, **kwargs):
  File "/usr/lib/python3.4/site-packages/pyanaconda/install.py", line 96, in doConfiguration
    ksdata.user.execute(storage, ksdata, instClass, u)
  File "/usr/lib/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
ValueError: User nobody already exists

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=/isolinux/initrd0.img root=live:UUID=CE27-5093 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 rd.live.check BOOT_IMAGE=/isolinux/vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.i686
other involved packages: python3-libs-3.4.3-5.fc23.i686
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Izzedine 2016-02-15 12:46:57 EST
Created attachment 1127377 [details]
File: anaconda-tb
Comment 2 Izzedine 2016-02-15 12:47:01 EST
Created attachment 1127378 [details]
File: anaconda.log
Comment 3 Izzedine 2016-02-15 12:47:03 EST
Created attachment 1127379 [details]
File: environ
Comment 4 Izzedine 2016-02-15 12:48:06 EST
Created attachment 1127380 [details]
File: journalctl
Comment 5 Izzedine 2016-02-15 12:48:12 EST
Created attachment 1127381 [details]
File: lsblk_output
Comment 6 Izzedine 2016-02-15 12:48:17 EST
Created attachment 1127382 [details]
File: nmcli_dev_list
Comment 7 Izzedine 2016-02-15 12:48:21 EST
Created attachment 1127383 [details]
File: os_info
Comment 8 Izzedine 2016-02-15 12:48:37 EST
Created attachment 1127384 [details]
File: program.log
Comment 9 Izzedine 2016-02-15 12:49:10 EST
Created attachment 1127385 [details]
File: storage.log
Comment 10 Izzedine 2016-02-15 12:49:25 EST
Created attachment 1127386 [details]
File: ifcfg.log
Comment 11 Izzedine 2016-02-15 12:49:27 EST
Created attachment 1127387 [details]
File: packaging.log
Comment 12 Brian Lane 2016-02-15 20:20:54 EST
Did you name your user 'nobody'? If so, you can work around this by naming your user 'somebody' :)
Comment 13 adam 2016-02-19 19:13:11 EST
Another user experienced a similar problem:

Error during instalation from live dist from USB

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.10-1.fc23.x86_64
product:        Fedora
reason:         ValueError: User adm already exists
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 14 adam 2016-02-20 03:59:14 EST
I think, the problem is in account creation, during installations process. I try install without creation user.
Comment 15 adam 2016-02-20 04:37:22 EST
I workaround this problem, I do not create any user during installation and installation was finished sucessfuly. But problem with anaconda still exist this is only workaround.
Comment 16 adam 2016-02-21 11:37:46 EST
Ok i knew exactly where the problem is. User nobody and adm are defined in system. But, this do not should stopped installation process. In this case installer  have to prompt user about this and continue without user creation. But now, installer is rollback all process and we have to start from beginning.
Comment 17 robert fairbrother 2016-04-04 20:41:04 EDT
Another user experienced a similar problem:

trying to install fedora 23 on a acer aspire netbook

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-i686-23-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.i686
other involved packages: python3-libs-3.4.3-5.fc23.i686
package:        anaconda-core-23.19.10-1.fc23.i686
product:        Fedora
reason:         ValueError: User users already exists
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 18 Brian Lane 2016-04-06 15:37:04 EDT
So as far as I can tell this boils down to "don't do that" but here's a patch to log it as a warning instead of crashing:

https://github.com/rhinstaller/anaconda/pull/583
Comment 19 Fedora Update System 2016-04-18 16:56:38 EDT
python-blivet-1.20.0-1.fc24 anaconda-24.13.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-45ca29d07c
Comment 20 Fedora Update System 2016-04-19 16:25:14 EDT
anaconda-24.13.4-1.fc24, python-blivet-1.20.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-45ca29d07c
Comment 21 Fedora Update System 2016-04-23 19:45:18 EDT
anaconda-24.13.4-1.fc24, python-blivet-1.20.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.