Bug 1308697 - VMs stuck in "Waiting for Launch" state until engine restarted, yet VMs were actually running on the host.
VMs stuck in "Waiting for Launch" state until engine restarted, yet VMs were ...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.7
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Vinzenz Feenstra [evilissimo]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 14:17 EST by Gordon Watson
Modified: 2016-02-25 07:44 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 02:48:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Watson 2016-02-15 14:17:53 EST
Description of problem:

After some VMs were restarted on a specific host, they got stuck in a 'Waiting for Launch' state, but only as seen by the engine. On the host, they were all 'Up' and the guests were accessible and working as expected.

As a test, one of these VMs was started on a different host and it came up ok. When it was then started on the same host as the ones that were "stuck", it too became stuck in 'Waiting for Launch'.

This sounded like a host-related issue at first, but since the easiest thing to try was to restart ovirt-engine, that was performed and that resolved the problem. Nothing was done of that host at all to affect this.


Version-Release number of selected component (if applicable):

RHEV 3.5.7
RHEV-H 7.2 (20160105.1.el7) hosts 


How reproducible:

Not.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 12 Vinzenz Feenstra [evilissimo] 2016-02-24 03:27:49 EST
Ok after all our investigations did go no where, I need to ask some more questions:

@Gordon:
- Are/Were there any 'Stateless' VMs running on the affected host?
- Is that issue still reproducible to the customer? If so, could you please try to give some more information on what you do when this happens?

Note You need to log in before you can comment on or make changes to this bug.