Bug 1308735 - Can click on OSP node registration error message and get taken to Review screen before you're supposed to be there
Can click on OSP node registration error message and get taken to Review scre...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: John Matthews
Landon LaSmith
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 17:00 EST by Matt Reid
Modified: 2016-09-13 12:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failed node registration error (36.29 KB, image/png)
2016-08-26 14:52 EDT, Landon LaSmith
no flags Details

  None (edit)
Description Matt Reid 2016-02-15 17:00:51 EST
Description of problem:
During OSP node registration, if you get an error, the message can be clicked on, and will take you to the Review - Progress Details screen, well before you've filled out enough information to get there.

We should try to disallow that, or see if we can make the needed information available on-demand, outside of the Review step.

Version-Release number of selected component (if applicable):
TP2

How reproducible:
every OSP error that produces a traceback

Additional info:
Comment 5 Landon LaSmith 2016-08-26 14:51:23 EDT
Marking as VERIFIED. I input an invalid mac address for node registration which eventually timed out.  The resulting error message displays the reason from openstack and is linked to the failed satellite task page "Label: Actions::Fusor::Host::IntrospectOpenStackNode"
Comment 6 Landon LaSmith 2016-08-26 14:52 EDT
Created attachment 1194442 [details]
Failed node registration error
Comment 7 Landon LaSmith 2016-08-26 14:58:07 EDT
Adding ISO Version used for verification: QCI-1.0-RHEL-7-20160824.t.1
Comment 9 errata-xmlrpc 2016-09-13 12:26:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.