This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1308822 - g++ <string> defines BIG_ENDIAN
g++ <string> defines BIG_ENDIAN
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gcc (Show other bugs)
7.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 03:39 EST by Anders Munch
Modified: 2016-02-16 03:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 03:52:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducing example. (58 bytes, text/x-csrc)
2016-02-16 03:39 EST, Anders Munch
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 0010377 None None None 2016-02-16 03:39 EST

  None (edit)
Description Anders Munch 2016-02-16 03:39:20 EST
Created attachment 1127526 [details]
Reproducing example.

Description of problem:
System headers define the identifier BIG_ENDIAN in a program that does not include any platform-specific headers, thus changing the meaning of a program that checks this particular symbol. Since BIG_ENDIAN is not a symbol reserved for the implementation, this is a standards violation.

Version-Release number of selected component (if applicable):
CentOS 7.2.1511

How reproducible:
Always.

Steps to Reproduce:
1. g++ -c big_endian_predefined.cpp

Actual results:
#error message

Expected results:
Successful compilation.

Additional info:
It looks like BIG_ENDIAN and other symbols like it become defined when __USE_BSD is defined.
Comment 2 Jakub Jelinek 2016-02-16 03:52:07 EST
The C++ compiler indeed predefines _GNU_SOURCE macro, because libstdc++ headers need various functions from that namespace.  This is a known bug, but is not going to be fixed at least until GCC 7, and requires some heavy coordination between glibc and gcc.
See e.g. https://gcc.gnu.org/bugzilla/show_bug.cgi?id=51749
Even after this is fixed upstream, this is not backportable to the RHEL 7 compiler and glibc.

Note You need to log in before you can comment on or make changes to this bug.