Bug 1308886 - [UI -General] - ToolTips continue to be displayed while they no longer relevant
[UI -General] - ToolTips continue to be displayed while they no longer relevant
Status: CLOSED RAWHIDE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3.1
x86_64 Linux
low Severity medium (vote)
: ovirt-4.0.0-rc
: ---
Assigned To: Greg Sheremeta
Pavel Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 06:01 EST by Michael Burman
Modified: 2016-06-10 15:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-10 15:28:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑4.0.0?
mburman: planning_ack?
mburman: devel_ack?
pstehlik: testing_ack+


Attachments (Terms of Use)
records (9.55 MB, application/x-gzip)
2016-02-16 06:01 EST, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2016-02-16 06:01:45 EST
Created attachment 1127568 [details]
records

Description of problem:
[UI -General] - ToolTips continue to be displayed while they no longer relevant.

I believe it is a general bug in the ToolTips UI, but i didn't tested all tooltips in the system.
I noticed this on 2 main network examples and tooltips continue to be displayed while they no longer relevant. 

Examples -->

1) If you have a DC 3.0 and DC 3.6 in your engine and the DC 3.0 is first in the list: 
DC_3_0(name) - 3.0(version
New_DC(name) - 3.6(version)

- When creating new network the dc 3.0 version appears first in the list and a MTU not supported tooltip is appeared. 
When switching to 3.6 DC, this tooltip continue to be displayed.  
- The same for editing a network that belong to dc 3.6, this MTU not supported tooltip continue to be displayed, although it's not relevant.
- If renaming the DC_3_0 to something like ZDC_3_0, it will now appear second in the list and we will not see the tooltip until switching to the 3.0 dc and then again this behavior will start.

2) When checking the 'passthrough' property on the vNIC profile, 2 tooltips displaying that QoS and Port mirroring are not supported and can't be changed.
If unchecking the the 'passthrough' property this tooltips are continued to be displayed.

Attaching records to describe it better.

- I believe there are more scenarios to such behavior. 
 
Version-Release number of selected component (if applicable):
3.6.3.1-0.1.el6

How reproducible:
100
Comment 1 Sandro Bonazzola 2016-05-02 05:55:52 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Yaniv Lavi (Dary) 2016-05-23 09:17:18 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 3 Yaniv Lavi (Dary) 2016-05-23 09:23:48 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Greg Sheremeta 2016-06-10 15:28:39 EDT
I watched the videos and tried out the behaviors. Thanks for reporting!

There is not a systemic bug that I see.

edit_network - this is already fixed in latest master (the dialog is redesigned, and the tooltip is gone)

edit_vnic_profile - this is an upstream gwtbootstrap3 bug. It will be fixed when we upgrade, which should be soon. X-Ref: https://github.com/gwtbootstrap3/gwtbootstrap3/issues/367

new_network - this is already fixed in latest master (the dialog is redesigned, and the tooltip is gone)

Closing nextrelease since these are so minor, and are or will be dealt with.

Note You need to log in before you can comment on or make changes to this bug.