Bug 1308957 - delete volume action link is shown even if it shouldn't
delete volume action link is shown even if it shouldn't
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Matthias Runge
Ido Ovadia
:
: 1308958 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 10:03 EST by Martin Pavlásek
Modified: 2016-02-17 06:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 03:30:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Pavlásek 2016-02-16 10:03:37 EST
Description of problem:
If volume has snaphost, it can't be deleted (need to remove them first). If you navigate to detail of the volume, there exists a link to Delete volume - and it shouldn't be there.


Version-Release number of selected component (if applicable):
RHEL 7.2
python-django-horizon-8.0.0-10.el7ost.noarch
openstack-dashboard-theme-8.0.0-10.el7ost.noarch
openstack-dashboard-8.0.0-10.el7ost.noarch
openstack-packstack-puppet-7.0.0-0.11.dev1692.g1b5e83b.el7ost.noarch
openstack-packstack-7.0.0-0.11.dev1692.g1b5e83b.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. log in as demo user
2. Project - Compute - Volumes
3. create Volume with default values, name it "test"
4. verify, that drop down menu of the row with "test" volume contain Delete volume
click to Create snapshot, name it as "test_snap"
navigate back to list of Volumes (not snapshots of them)
verify, that drop down menu of the row with "test" volume does NOT contain Delete volume
click to name of the volume to navigate to detail of volume "test"
on the right top of page there is action button with dropdown menu. There is Delete volume item, that is not accessible from list of volumes


Actual results:
Delete volume item on detail page shouldn't be there, if there exists snapshot of it

Expected results:
Delete volume is visible always (or seems to be)

Additional info:
Comment 2 Matthias Runge 2016-02-16 11:12:04 EST
*** Bug 1308958 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Runge 2016-02-17 03:29:43 EST
Reported upstream, this is not a downstream only issue.
Comment 4 Matthias Runge 2016-02-17 06:39:55 EST
Just verified, the delete action is hidden for a volume, when there was a snapshot made from that volume. Not sure, if I understood your bug report correctly.

This isn't reproducible in Kilo - master branch.

Note You need to log in before you can comment on or make changes to this bug.