Bug 1309084 - [Docs] [Director] Document for update 7.x to 7.3
[Docs] [Director] Document for update 7.x to 7.3
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
x86_64 Linux
high Severity high
: y3
: 7.0 (Kilo)
Assigned To: Dan Macpherson
Alexander Chuzhoy
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 14:46 EST by Dan Yasny
Modified: 2016-04-13 00:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 00:53:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2016-02-16 14:46:53 EST
We need to track adding the following BZs to the update documentation:

 (1) https://bugzilla.redhat.com/show_bug.cgi?id=1307125 - heat-engine crash ( workaround with docs) 
 (2)  https://bugzilla.redhat.com/show_bug.cgi?id=1308702 ( RPC_Timeout is not 600 ( workaround with docs)

Version-Release number of selected component (if applicable):
7.x->7.3
Comment 3 Andrew Dahms 2016-02-16 20:26:35 EST
Assigning to Dan for review.
Comment 7 Alexander Chuzhoy 2016-02-24 12:02:53 EST
Bz #1:

Under section 9.1.

Important
After the package update, make sure all OpenStack services are running properly on the director. Check the ironic-api and ironic-discoverd services are running. If not, please start them:

$ sudo systemctl restart openstack-ironic-api openstack-ironic-discoverd

Likewise, heat-engine on the Undercloud can fail to start if its database is unavailable. If this occurs, restart heat-engine manually after the update:

$ sudo systemctl start openstack-heat-engine.service



Bz #2:
If upgrading from OpenStack Platform director 7.2 to OpenStack Platform director 7.3 or greater:

    Heat on the Undercloud requires an increase in the RPC response timeout to accomodate a known issue (see BZ#1305947). Edit the /etc/heat/heat.conf and set the following parameter:

    rpc_response_timeout=600

    Then restart all Heat services:

    $ systemctl restart openstack-heat-api.service
    $ systemctl restart openstack-heat-api-cfn.service
    $ systemctl restart openstack-heat-engine.service
Comment 10 Zane Bitter 2016-02-29 21:07:50 EST
We don't re-run Puppet after upgrading the undercloud, so if the undercloud was originally installed with a version of openstack-puppet-modules that exhibited bug 1305947 (i.e. 7.2), it will NOT be fixed after upgrading to 7.3 and the user will still have to apply the second workaround above.

The first workaround should not actually be needed with respect to heat-engine though, because we included a fix for bug 1307125 in 7.3.
Comment 11 Zane Bitter 2016-02-29 21:10:44 EST
Actually, the build that fixed bug 1307125 may not be in 7.3 after all; it seems to still be ON_QA.
Comment 12 Dan Macpherson 2016-03-01 00:07:58 EST
Sasha, based on Zane's comments, it looks like we'll be keeping both workarounds in the docs. Do you know if there's anything else required for this BZ?
Comment 13 Alexander Chuzhoy 2016-03-02 15:18:30 EST
Verified
Nothing else is required for the bz.
The doc looks OK.
Thanks.
Comment 14 Andrew Dahms 2016-04-13 00:53:24 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.