This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1309092 - No man pages installed on RHCI server
No man pages installed on RHCI server
Status: CLOSED WONTFIX
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Matthews
Dave Johnson
: Triaged
: 1309093 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 15:04 EST by Tasos Papaioannou
Modified: 2016-06-15 15:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 15:12:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tasos Papaioannou 2016-02-16 15:04:03 EST
Description of problem:

The RHCI installation ISO installs packages with the excludedocs option, resulting in no man pages / docs installed on the server.

# grep packages ks.cfg 
%packages --excludedocs --nobase

Version-Release number of selected component (if applicable):

RHCI-6.0-RHEL-7-20160208.1-RHCI-x86_64-dvd1.iso

How reproducible:

100%

Steps to Reproduce:
1.) Install RHCI from ISO.
2.) Try to view man page for any installed package.

# rpm -ql net-tools|grep /usr/share/man/man8/route.8.gz
/usr/share/man/man8/route.8.gz

# man route
No manual entry for route


Actual results:

No installed man / doc pages.

Expected results:

Installed man / doc pages.

Additional info:
Comment 1 Dave Johnson 2016-02-17 10:55:47 EST
*** Bug 1309093 has been marked as a duplicate of this bug. ***
Comment 2 John Matthews 2016-06-15 15:12:15 EDT
As per PM closing, reasoning is we want to keep ISO size low as we can.

Note You need to log in before you can comment on or make changes to this bug.