Bug 130916 - /etc/firmware/microcode.dat is out of date
/etc/firmware/microcode.dat is out of date
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 121553 135785 (view as bug list)
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-08-25 15:04 EDT by Don Buchholz
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 13:28:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Buchholz 2004-08-25 15:04:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
Intel recently announced a microcode update to their Pentium 4 and
Xeon processors to fix a timing problem in the instruction decode
unit.  Some hardware vendors (e.g. IBM and HP) have release BIOS
updates to load new microcode.  Others (e.g. whitebox/clone vendors)
have not.

Intel's docs do specify the microcode fix must be loaded early in the
POST process (prior to memory initialization), but it is not clean if
that is a generic statement, or actual requirement to fix the problem.

microcode.dat in kernel-utils-2.4-8.37.5.i386.rpm is datestamped with
May-2001.  Code from http://www.urbanmyth.org/microcode is dated
27-Jul-2004 (consistent with BIOS update info from IBM).


Version-Release number of selected component (if applicable):  
2.4-8.37.5

How reproducible:
Always

Steps to Reproduce:
    

Additional info:

The intel-ia32microcode-27July2004.txt file from
www.urbanmyth.org/microcode will load w/o error using the existing
microcode_ctl utility.

See also --
  http://www.beowulf.org/pipermail/beowulf/2004-July/017215.html
 
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-43902
     (note IBM deems this issue "critical")

  http://www-1.ibm.com/support/docview.wss?uid=psg1MIGR-55708

  http://developer.intel.com/design/xeon/documentation.htm#updates
Comment 1 Dave Jones 2005-01-18 01:01:29 EST
*** Bug 135785 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2005-01-18 01:02:45 EST
*** Bug 121553 has been marked as a duplicate of this bug. ***
Comment 7 Dennis Gregorovic 2005-05-19 13:28:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-228.html

Note You need to log in before you can comment on or make changes to this bug.