Bug 1309261 - Blank page on accessing host-collection and firebug filled with Error: [$injector:unpr] Unknown provider: urlencodeFilterProvider <- urlencodeFilter
Blank page on accessing host-collection and firebug filled with Error: [$inje...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Katello Bug Bin
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
: 1313743 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 05:36 EST by Sachin Ghai
Modified: 2016-07-27 07:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:31:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blank page on accessing host-collection and firebug raises error (68.65 KB, image/png)
2016-02-17 05:36 EST, Sachin Ghai
no flags Details
host-collection page is loading correctly (38.52 KB, image/png)
2016-05-13 07:17 EDT, Sachin Ghai
no flags Details
host-collection page is loading correctly from firefox too (61.01 KB, image/png)
2016-05-13 08:18 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13751 None None None 2016-04-22 11:07 EDT

  None (edit)
Description Sachin Ghai 2016-02-17 05:36:46 EST
Created attachment 1127910 [details]
blank page on accessing host-collection and firebug raises error

Description of problem:
On accessing the host-collection via webUI, blank page appears. And firebug is filled-up with some errors. Please see the screenshot.


Version-Release number of selected component (if applicable):
Nightly

foreman-release-1.11.0-0.develop.201602111150gitf6014fb.el7.noarch
katello-installer-2.5.0-1.nightly.201602120122git5f95a31.el7.noarch
katello-2.5.0-4.nightly.el7.noarch


How reproducible:
always

Steps to Reproduce:
1. Go to Hosts -> Host-collection
2.
3.

Actual results:
Blank page appears and firebug raises following error:

Error: [$injector:unpr] Unknown provider: urlencodeFilterProvider <- urlencodeFilter
http://errors.angularjs.org/1.2.9/$injector/unpr?p0=urlencodeFilterProvider%20%3C-%20urlencodeFilter

Expected results:
Host-collection page should be opened up without any error.

Additional info:
Comment 1 Sachin Ghai 2016-02-17 05:38:35 EST
Created redmine issue http://projects.theforeman.org/issues/13751 from this bug
Comment 3 Bryan Kearney 2016-02-17 06:00:47 EST
Upstream bug component is Content Management
Comment 4 Brad Buckingham 2016-03-02 05:11:24 EST
*** Bug 1313743 has been marked as a duplicate of this bug. ***
Comment 5 Bryan Kearney 2016-04-04 22:00:54 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13751 has been closed
Comment 6 Sachin Ghai 2016-05-13 07:16:33 EDT
Verified with sat6.2 GA snap11.

I can see host-collection page without any error in developer tools and firebug. I can create host-collection too.
Comment 7 Sachin Ghai 2016-05-13 07:17 EDT
Created attachment 1157072 [details]
host-collection page is loading correctly
Comment 8 Sachin Ghai 2016-05-13 08:18 EDT
Created attachment 1157093 [details]
host-collection page is loading correctly from firefox too
Comment 9 Bryan Kearney 2016-07-27 07:31:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.