Bug 1309352 - file /etc/dbus-1/system.d is not owned by any package
file /etc/dbus-1/system.d is not owned by any package
Status: CLOSED DUPLICATE of bug 1285033
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 10:21 EST by Lukas Slebodnik
Modified: 2016-02-17 14:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 14:03:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2016-02-17 10:21:24 EST
Description of problem:
Most of dbus directories are owned by the dbus package:
  sh$ rpm -qf /etc/dbus-1/ /usr/share/dbus-1/ /usr/share/dbus-1/interfaces/ /usr/share/dbus-1/services/ /usr/share/dbus-1/system-services/
  dbus-1.10.6-1.fc23.x86_64
  dbus-1.10.6-1.fc23.x86_64
  dbus-1.10.6-1.fc23.x86_64
  dbus-1.10.6-1.fc23.x86_64
  dbus-1.10.6-1.fc23.x86_64

It will be good if the directory /etc/dbus-1/system.d would be owned as well [1]

Version-Release number of selected component (if applicable):
rpm -q dbus dbus-libs
dbus-1.10.6-1.fc23.x86_64
dbus-libs-1.10.6-1.fc23.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. rpm -qf /etc/dbus-1/system.d/
file /etc/dbus-1/system.d is not owned by any package

sh$ echo $?

Actual results:
/etc/dbus-1/system.d is not owned by any package.

Expected results:
/etc/dbus-1/system.d should be owned by dbus

Additional info:
BTW these directories are owned by libdbus(equivalend of dbus-libs) on opensuse.
  sh$ rpm -qf /etc/dbus-1/ /etc/dbus-1/system.d/ /usr/share/dbus-1/ /usr/share/dbus-1/interfaces/ /usr/share/dbus-1/services/ /usr/share/dbus-1/system-services/
  libdbus-1-3-1.8.20-1.1.x86_64
  libdbus-1-3-1.8.20-1.1.x86_64
  libdbus-1-3-1.8.20-1.1.x86_64
  libdbus-1-3-1.8.20-1.1.x86_64
  libdbus-1-3-1.8.20-1.1.x86_64
  libdbus-1-3-1.8.20-1.1.x86_64

IMHO we could do the same on fedora and packages which depends only on dbus-libs would not violate fedora packaging guidelines[1]

[1] http://fedoraproject.org/wiki/Packaging:Guidelines#File_and_Directory_Ownership
Comment 1 David King 2016-02-17 14:03:32 EST

*** This bug has been marked as a duplicate of bug 1285033 ***

Note You need to log in before you can comment on or make changes to this bug.