Bug 1309375 - Asus Q551LN screen brightness keys only work with acpi_osi=NULL
Asus Q551LN screen brightness keys only work with acpi_osi=NULL
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 11:11 EST by Agustin Barto
Modified: 2017-04-15 09:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-15 09:03:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Agustin Barto 2016-02-17 11:11:24 EST
Description of problem:

My Asus laptop model Q551LN brightness keys won't work on Fedora 23 unless I use the acpi_osi= workaround on the grub command line.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot Fedora 23 normally
2. Hit the brightness keys (Fn+F5 and Fn+F6)
3. Reboot Fedora 23 adding "acpi_osi=" to the GRUB command lie
4. Hit the brightness keys (Fn+F5 and Fn+F6)

Actual results:

No results in step #2, brightness keys work fine in step #4.

Expected results:

Brightness keys should work out of the box.

Additional info:

There have been similar problems with other Asus laptops:

https://bugzilla.kernel.org/show_bug.cgi?id=70241
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1348890
Comment 1 Laura Abbott 2016-09-23 15:26:03 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 2 Laura Abbott 2017-01-16 20:12:53 EST
*********** MASS BUG UPDATE **************
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.
 
Fedora 25 has now been rebased to 4.9.3-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.
 
If you experience different issues, please open a new bug report for those.
Comment 3 Agustin Barto 2017-01-17 15:02:31 EST
The bug is still present with 4.9.3-200.fc25.
Comment 4 Justin M. Forbes 2017-04-11 10:37:18 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.
Comment 5 Agustin Barto 2017-04-15 09:03:41 EDT
The bug is no longer present in kernel-4.10.9-200.fc25.x86_64.

Note You need to log in before you can comment on or make changes to this bug.