Bug 1309442 - evm.log error: undefined method 'vmConfig' for #<MiqOpenStackImage:0x<hex_string>
evm.log error: undefined method 'vmConfig' for #<MiqOpenStackImage:0x<hex_str...
Status: NEW
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - CloudForms (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: John Matthews
Dave Johnson
Dan Macpherson
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 15:05 EST by Thom Carlin
Modified: 2016-09-27 18:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2016-02-17 15:05:04 EST
Description of problem:

Error in /var/www/miq/vmdb/log/evm.log

Version-Release number of selected component (if applicable):

TP2 RC9

How reproducible:

Uncertain

Steps to Reproduce:
1. Install RHCI+TripleO ISOs
2. Deploy OpenStack + CloudForms
3. Run instance smartstate analysis
4. Check logs

Actual results:

Error in log

Expected results:

No error
Successful SmartState Analysis

Additional info:

[----] E, [datestamp, etc.] ERROR -- : MIQExtract undefined method `vmConfig' for #<MiqOpenStackImage:0x<hex_string>>
[----] E, [datestamp, etc.] ERROR -- : MIQExtract /var/www/miq/vmdb/gems/pending/OpenStackExtract/MiqOpenStackVm?MiqOpenStackImage.rb: 96 in `method_missing'
[...]MiqExtract.rb:162:in `getVMConfig'
[...]
[----] E, [datestamp, etc.] ERROR -- : MIQ(ManageIQ::Providers::Openstack::CloudManager::Template#scan_via_miq_vm) Error: No XML returned for category [vmconfig] TaskId:[uuid] VM:[deployment_name-cfme]
[...]
[----] E, [datestamp, etc.] ERROR -- : Q_task_id([uuid]) MIQ(ManageIQ::Providers::OpenStack::CloudManager::Template#add_elements) Adding XML elements for [1000000000001] from [miq]
[----] E, [datestamp, etc.] ERROR -- : Q_task_id ([uuid]) (ActiveRecord::UnknownAttributeError] unknown attribute 'type' for Network. Method:[rescue in block in add_elements]
[----] E, [datestamp, etc.] ERROR -- : Q_task_id ([uuid]) /opt/rh/cfme-gemset/gems/activerecord-4.2.51/lib/active_record/attribute_assignment.rb:59 in `rescue in _assign_attribute'
[...]attribute_assignment.rb:54 in '_assign_attribute'
[...]ENOSPC error

Note You need to log in before you can comment on or make changes to this bug.