Bug 1309522 - Username and documentation overlaps with OPENSHIFT ORIGIN logo on /console page for IE11
Username and documentation overlaps with OPENSHIFT ORIGIN logo on /console pa...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Robb Hamilton
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 21:23 EST by yapei
Modified: 2016-05-12 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:14:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IE11Console (33.31 KB, image/png)
2016-02-17 21:23 EST, yapei
no flags Details
IE11HomeLink (17.16 KB, image/png)
2016-02-17 21:24 EST, yapei
no flags Details
IE11Overlap (36.41 KB, image/png)
2016-02-18 22:35 EST, yapei
no flags Details

  None (edit)
Description yapei 2016-02-17 21:23:15 EST
Description of problem:
On IE11, when open /console page,user-dropdown element and documentation dropdown overlaps with OPENSHIFT ORIGIN logo on the left upper corner

Version-Release number of selected component (if applicable):
devenv-rhel7_3449
IE11

How reproducible:
Always

Steps to Reproduce:
1.Login to openshift web console

Actual results:
1.username and documentation overlaps with ORIGIN logo on /console page, refer to attachment

Expected results:
1. /console page should display well

Additional info:
Firefox44, Chrome47, Edge25, Safari9 works fine
Comment 1 yapei 2016-02-17 21:23 EST
Created attachment 1128124 [details]
IE11Console
Comment 2 yapei 2016-02-17 21:24 EST
Created attachment 1128125 [details]
IE11HomeLink
Comment 3 Robb Hamilton 2016-02-18 14:08:49 EST
Ya, I am unable to reproduce this bug in IE11.  I can, however, reproduce it in IE10.  Can you confirm that you're able to reproduce in IE11?
Comment 4 yapei 2016-02-18 22:35 EST
Created attachment 1128408 [details]
IE11Overlap
Comment 5 yapei 2016-02-18 22:36:18 EST
Add a screenshot to show what happens on my side
Comment 6 Robb Hamilton 2016-02-19 08:49:17 EST
Ah ha!  This bug is occurring because the CSS builds are different.

CSS served over port 8443:

@media (min-width: 768px) {
  .components .components-panel .component-block .component.meta-data {
    -moz-flex: 1 1 0%;
    flex: 1 1 0%;
  }
}

CSS served over port 9000:

@media (min-width:768px){.components .components-panel .component-block .component.meta-data{-webkit-flex:1 1 0;-moz-flex:1 1 0;-ms-flex:1 1 0;flex:1 1 0}}

Both are problematic.  8443 is missing the additional prefixed values.  The latter is missing the "%" unit declarations required to overcome an IE10-11 bug (see https://github.com/philipwalton/flexbugs#workaround-3).  

Jessica, I've yet to fully understand the Gruntfile.  Can you help?
Comment 7 Robb Hamilton 2016-02-19 17:05:49 EST
https://github.com/openshift/origin/pull/7475 should resolve this bug.
Comment 8 yapei 2016-03-01 00:53:11 EST
checked against devenv-rhel7_3568, issue is fixed

move to verified

Note You need to log in before you can comment on or make changes to this bug.