Bug 1309549 - Skipping loading of repo_auth plugins since no entry for "required_path"
Skipping loading of repo_auth plugins since no entry for "required_path"
Status: CLOSED WONTFIX
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: CDS (Show other bugs)
2.1.3
All Linux
high Severity high
: ---
: 3.0.0
Assigned To: John Matthews
Martin Kočí
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 00:38 EST by Anand Vaddarapu
Modified: 2016-07-13 09:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-13 09:22:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Vaddarapu 2016-02-18 00:38:43 EST
Description of problem:

found lots of error logs in /var/log/httpd/ssl_error_log in cds2 server, is there anything wrong? 

[Thu Feb 04 17:26:14 2016] [error] [client x.x.x.x] Skipping loading of repo_auth plugins since no entry for "required_path" in [plugins] section.
[Thu Feb 04 17:26:14 2016] [error] [client x.x.x.x] Skipping loading of repo_auth plugins since no entry for "required_path" in [plugins] section.
[Thu Feb 04 17:26:14 2016] [error] [client x.x.x.x] Skipping loading of repo_auth plugins since no entry for "required_path" in [plugins] section.
[Thu Feb 04 17:26:16 2016] [error] [client x.x.x.x] Skipping loading of repo_auth plugins since no entry for "required_path" in [plugins] section.

[plugins] section in /etc/pulp/repo_auth.conf, like below:
[main]
enabled: true
log_failed_cert: true
log_failed_cert_verbose: false
max_num_certs_in_chain: 100

[repos]
cert_location: /etc/pki/pulp/content
global_cert_location: /etc/pki/pulp/content
protected_repo_listing_file: /etc/pki/pulp/content/pulp-protected-repos

[crl]
location: /etc/pki/pulp/content


According to the code, if plugin path set to none then it produces the error.
**
def _load_plugins(environ):
    '''
    Load required authentication plugins dynamically.
    '''

    config = SafeConfigParser()
    config.read(CONFIG_FILENAME)

    try:
        required_plugin_path = config.get('plugins', 'required_path')
    except Exception, e:
        required_plugin_path = None
        environ["wsgi.errors"].write('Skipping loading of repo_auth plugins since no entry for "required_path" in [plugins] section.')
        return
**

Version-Release number of selected component (if applicable):


How to get rid of this error.
Comment 4 Patrick Creech 2016-07-13 09:22:03 EDT
This does not appear to be relevant in pulp-2.8, which will be used in RHUI-3

Note You need to log in before you can comment on or make changes to this bug.