Bug 1309587 - [abrt] BUG: unable to handle kernel NULL pointer dereference at 0000000000000380
[abrt] BUG: unable to handle kernel NULL pointer dereference at 0000000000000380
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c532914447291ad7e16541d022b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 03:24 EST by Juan Orti
Modified: 2016-10-03 07:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 07:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (97.45 KB, text/plain)
2016-02-18 03:24 EST, Juan Orti
no flags Details

  None (edit)
Description Juan Orti 2016-02-18 03:24:07 EST
Additional info:
reporter:       libreport-2.6.4
BUG: unable to handle kernel NULL pointer dereference at 0000000000000380
IP: [<ffffffff81366d65>] bio_get_nr_vecs+0x15/0x40
PGD 0 
Oops: 0000 [#1] SMP 
Modules linked in: hfsplus hfs minix msdos jfs xfs libcrc32c xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun xt_set xt_multiport ip_set_hash_ip ip_set nfnetlink nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge ebtable_filter ebtable_nat ebtables ip6table_mangle ip6table_raw ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_filter ip6_tables iptable_mangle iptable_raw iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack vfat fat uvcvideo videobuf2_vmalloc videobuf2_core videobuf2_memops v4l2_common videodev media intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp kvm_intel kvm snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi
 crct10dif_pclmul crc32_pclmul snd_hda_intel snd_hda_codec snd_usb_audio snd_hda_core snd_usbmidi_lib snd_hwdep snd_rawmidi snd_seq snd_seq_device snd_pcm fuse snd_timer iTCO_wdt iTCO_vendor_support snd eeepc_wmi asus_wmi sparse_keymap rfkill mei_me lpc_ich joydev i2c_i801 shpchp soundcore mei video wmi nfsd auth_rpcgss nfs_acl lockd grace sunrpc binfmt_misc btrfs xor raid6_pq amdkfd amd_iommu_v2 radeon i2c_algo_bit drm_kms_helper ttm crc32c_intel drm 8021q serio_raw garp stp llc mrp r8169 mii
CPU: 1 PID: 1626 Comm: transmission-da Not tainted 4.2.8-300.fc23.x86_64 #1
Hardware name: System manufacturer System Product Name/P8Z68-V LE, BIOS 4102 09/09/2013
task: ffff8803f8cc0000 ti: ffff8803dffb4000 task.ti: ffff8803dffb4000
RIP: 0010:[<ffffffff81366d65>]  [<ffffffff81366d65>] bio_get_nr_vecs+0x15/0x40
RSP: 0018:ffff8803dffb7a88  EFLAGS: 00010246
RAX: 0000000000000000 RBX: 0000000000001000 RCX: 0000000000000100
RDX: 0000000000000100 RSI: ffffffffffffffff RDI: ffff88040dc296c0
RBP: ffff8803dffb7a88 R08: 000000010050516f R09: ffff88040c142000
R10: ffff8803777928a0 R11: 0000000000000000 R12: ffff8803dffb7d30
R13: 0000000000000000 R14: 0000000130e7b360 R15: ffff88007f2c97b0
FS:  00007fc64ffa0700(0000) GS:ffff88041ec40000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000000000380 CR3: 00000003df687000 CR4: 00000000000406e0
Stack:
 ffff8803dffb7ae8 ffffffffa035dae7 0000000000000000 0000000000000000
 0000000000000000 ffffea000e2b3740 ffff8803dffb7b68 0000000000000000
 ffffea000e2b3740 0000000000000000 ffff8803dffb7d40 000000000da6c000
Call Trace:
 [<ffffffffa035dae7>] submit_extent_page+0x177/0x1e0 [btrfs]
 [<ffffffffa035ec4e>] __do_readpage+0x39e/0x910 [btrfs]
 [<ffffffffa035d1a0>] ? btrfs_create_repair_bio+0x100/0x100 [btrfs]
 [<ffffffffa0341a30>] ? btrfs_real_readdir+0x570/0x570 [btrfs]
 [<ffffffffa035f584>] __extent_readpages.constprop.41+0x2c4/0x2e0 [btrfs]
 [<ffffffff811a26f6>] ? __add_to_page_cache_locked+0x1c6/0x2b0
 [<ffffffffa0341a30>] ? btrfs_real_readdir+0x570/0x570 [btrfs]
 [<ffffffffa035fc2e>] extent_readpages+0x1de/0x1f0 [btrfs]
 [<ffffffffa0341a30>] ? btrfs_real_readdir+0x570/0x570 [btrfs]
 [<ffffffff811f50e1>] ? alloc_pages_current+0x91/0x100
 [<ffffffffa033f74f>] btrfs_readpages+0x1f/0x30 [btrfs]
 [<ffffffff811b1286>] __do_page_cache_readahead+0x1b6/0x230
 [<ffffffff811b161a>] force_page_cache_readahead+0x3a/0x60
 [<ffffffff811e6546>] SyS_fadvise64+0x1f6/0x250
 [<ffffffff8177a2ae>] entry_SYSCALL_64_fastpath+0x12/0x71
Code: 5b 5d c3 e8 5e 75 d3 ff 90 90 90 90 90 90 90 90 90 90 90 90 90 90 66 66 66 66 90 48 8b 87 98 00 00 00 55 b9 00 01 00 00 48 89 e5 <48> 8b 90 80 03 00 00 5d 8b 82 00 07 00 00 0f b7 92 2a 07 00 00 
RIP  [<ffffffff81366d65>] bio_get_nr_vecs+0x15/0x40
Comment 1 Juan Orti 2016-02-18 03:24:17 EST
Created attachment 1128160 [details]
File: dmesg
Comment 2 Laura Abbott 2016-09-23 15:25:58 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 3 Juan Orti 2016-10-03 07:24:29 EDT
I haven't seen this again.

Note You need to log in before you can comment on or make changes to this bug.