Bug 1309608 - Smooth upgrade
Smooth upgrade
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: 8.0 (Liberty)
Assigned To: Angus Thomas
yeylon@redhat.com
:
: 1309605 1309606 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 04:38 EST by Hideki Kawai
Modified: 2016-04-18 03:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 10:22:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hideki Kawai 2016-02-18 04:38:51 EST
Description of problem:

Currently, it is necessary to stop services to upgrade OpenStack, and OpenStack needs to be upgraded with every verison. 
(Ex. Kilo->Liberty, Liberty->Mitaka)

We need a smooth upgrade where OpenStack can be upgraded without stopping resources already provisioned, and it allows skip of some versions.
(Ex. Kilo -> Mitaka, Icehouce->Mitaka)
Comment 2 Stephen Gordon 2016-02-18 07:47:32 EST
*** Bug 1309605 has been marked as a duplicate of this bug. ***
Comment 3 Stephen Gordon 2016-02-18 07:48:16 EST
*** Bug 1309606 has been marked as a duplicate of this bug. ***
Comment 4 Nick Barcet 2016-02-18 10:22:54 EST
Unfortunately, this would involve having the OpenStack community accept that we need to have stability on the internal communication process (RPC) that is being used to communicate between controllers and agents.  It was already an enormous push to get this happening for N -> N+1, and is barely completed with Mitaka.  I am not sure we will be able to make this happen in a short term release without blocking the project's evolution more than what would be acceptable by upstream.

Note You need to log in before you can comment on or make changes to this bug.