Bug 1309623 - There should be no 'max' in error prompt 'bps/iops/max total values and read/write values cannot be used at the same time'
There should be no 'max' in error prompt 'bps/iops/max total values and read/...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.8
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Fam Zheng
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 05:29 EST by Gu Nini
Modified: 2016-03-08 19:18 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 19:18:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gu Nini 2016-02-18 05:29:35 EST
Description of problem:
The error prompt 'bps/iops/max total values and read/write values cannot be used at the same time' is incorrect with 'max' included.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Start a guest with io throttling parameters bps(iops) and the corresponding read/write ones bps_rd/bps_wr(iops_rd/iops_wr) at the same time, take following qemu cmd line as an example:

# /usr/libexec/qemu-kvm -name rhel6.8 -enable-kvm -m 4G -smp 4 -uuid ae361e8d-288b-4e70-8783-bda0d450ce35 -nodefconfig --nodefaults -boot order=cd,menu=on -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=03 -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/iothrottling_nfsc/rhel6.8 -device scsi-hd,id=image1,drive=drive_image1,bootindex=0 -drive file=/home/kvm_autotest_root/iso/linux/RHEL6.8-Server-x86_64.iso,media=cdrom,id=cdrom,if=none -device ide-drive,drive=cdrom,bootindex=1 -vnc 0.0.0.0:10 -vga cirrus -monitor stdio -qmp tcp:0:4444,server,nowait -netdev tap,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:52:5a:30:2e:58,bus=pci.0,addr=0x7 -drive id=drive_image2,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/iothrottling_nfsc/hd1,bps=1024000,bps_rd=1024000 -device scsi-hd,id=image2,drive=drive_image2
qemu-kvm: -drive id=drive_image2,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/iothrottling_nfsc/hd1,bps=1024000,bps_rd=1024000: bps/iops/max total values and read/write values cannot be used at the same time

2. The error prompt is incorrect with 'max' as above


Actual results:
The error prompt 'bps/iops/max total values and read/write values cannot be used at the same time' is with 'max'

Expected results:
Max should not be included since RHEL6 don't support FOO_max.

Additional info:
Comment 1 Gu Nini 2016-02-18 05:33:48 EST
(In reply to Gu Nini from comment #0)
> Description of problem:
> The error prompt 'bps/iops/max total values and read/write values cannot be
> used at the same time' is incorrect with 'max' included.
> 
> Version-Release number of selected component (if applicable):
> 
Host kernel: 2.6.32-610.el6.x86_64
Qemu-kvm: qemu-kvm-rhev-0.12.1.2-2.488.el6.x86_64
Comment 4 Fam Zheng 2016-03-08 19:18:34 EST
Yes, the impact is low enough for WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.