Bug 130965 - personality syscall parameters not decoded
personality syscall parameters not decoded
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 01:57 EDT by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 22:03:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to implement PER_ option decoding (1.03 KB, patch)
2004-08-26 02:00 EDT, Ulrich Drepper
no flags Details | Diff

  None (edit)
Description Ulrich Drepper 2004-08-26 01:57:25 EDT
Description of problem:
The parameters of the personality syscall are not decoded.  This has
two reasons:
a) the PER_ values are no macros, so all the #ifdef PER_xxx tests fail
b) a number of values are missing

Version-Release number of selected component (if applicable):
strace-4.5.6-1

How reproducible:
always

Steps to Reproduce:
1.strace setarch -3 i386 /bin/echo
2.
3.
  
Actual results:
personality(0x8000008 /* PER_??? */)    = 0


Expected results:
personality(PER_LINUX32_3GB)            = 0


Additional info:
I'll attach a patch.
Comment 1 Ulrich Drepper 2004-08-26 02:00:54 EDT
Created attachment 103111 [details]
Patch to implement PER_ option decoding

The patch assumes that recent kernel headers are available since we cannot test
using #ifdef whether the PER_ values are defined.  The only alternative is to
define the value in system.c and not rely on kernel headers.  Your choice.
Comment 2 Roland McGrath 2004-08-31 02:46:39 EDT
I put a fix in upstream.
Comment 3 Roland McGrath 2004-08-31 22:03:04 EDT
4.5.7-2 is in rawhide.  I'll make an FC2 update release in a few days.
Comment 4 Tim Powers 2005-05-19 17:09:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-131.html

Note You need to log in before you can comment on or make changes to this bug.