This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1309672 - [KDE] Interface elements with text fields redraw problems
[KDE] Interface elements with text fields redraw problems
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 07:22 EST by Eugene Saenko
Modified: 2016-12-20 13:48 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 13:48:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Superposition new and old contents of text field. (5.05 KB, image/png)
2016-02-18 07:22 EST, Eugene Saenko
no flags Details

  None (edit)
Description Eugene Saenko 2016-02-18 07:22:50 EST
Created attachment 1128211 [details]
Superposition new and old contents of text field.

Description of problem:


Version-Release number of selected component (if applicable):

libreoffice-core-5.0.5.2-1.fc23.i686
plasma-workspace-5.5.4-2.fc23.i686

How reproducible:

When change interface item with text content, new text is placed into the field, but old text doesn't disappear making superposition of two contents.


Steps to Reproduce:
1. Open document in LO Writer.
2. Select any fragment of text.
3. Change name of the font.

Actual results:
We see superposition of old and new text in the field "Font Name"

Expected results:
We see only new fontname.

Additional info:
1. This effect is observed only in interface text fields. For example in the "File Open" dialog when option "Use LibreOffice dialogs" is selected.
2. This effect appears only if LibreOffice works under Plasma (KDE) and isn't observed when working under XFCE.
Comment 1 Caolan McNamara 2016-02-19 03:33:51 EST
yet another KDE related issue.
Comment 2 Eugene Saenko 2016-02-26 02:39:05 EST
After some updates the problem solved. 
All text elements of interface work fine.
I don't know which of updates solved the problem since I mostly worked under XFCE.
Comment 3 Eugene Saenko 2016-04-01 03:15:42 EDT
I was too fast. The problem came back again.
Comment 4 David H. Gutteridge 2016-06-29 17:49:10 EDT
I believe this is related to bug 1291074, as it's the same sort of issue I was seeing, except I was hitting it under Gnome instead of KDE. The effect is identical, and I saw it with font lists sometimes too. (It was just easier to reproduce with the find box, which is why I reported that under the reproduction steps.)
Comment 5 Fedora End Of Life 2016-11-24 10:37:38 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2016-12-20 13:48:39 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.