Bug 1309695 - Document newly supported HP keyboard KUS1206 with builtin smartcard reader and the keyboard hang issue
Document newly supported HP keyboard KUS1206 with builtin smartcard reader an...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: Red_Hat_Enterprise_Linux-Release_Notes-6-en-US (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Aneta Šteflová Petrová
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 08:59 EST by Asha Akkiangady
Modified: 2017-03-14 02:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
The HP keyboard KUS1206 does not handle smart cards correctly and can become unresponsive When using the HP keyboard KUS1206 with a built-in smart card reader, you might experience the following problems: * The keyboard detects smart cards inconsistently. * When the user logs in to the system with a password and the smart card is not inserted, the following message appears continuously in the /var/log/messages file: Mar 3 15:05:52 [host_name] pcscd: commands.c:957:CmdGetSlotStatus Card absent or mute * The keyboard sometimes becomes unresponsive.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-14 02:37:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asha Akkiangady 2016-02-18 08:59:14 EST
Description of problem:
Now the ccid support HP keyboard KUS1206 with builtin smartcard reader in RHEL 6.8. There is a hardware issue that trigger the keyboard hang need to be documented (https://bugzilla.redhat.com/show_bug.cgi?id=1229459#c40)

Version-Release number of selected component (if applicable):
ccid-1.3.9-8.el6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 2 Aneta Šteflová Petrová 2017-02-21 10:30:38 EST
Asha, I found this BZ when going through old doc bugs. Is this a request to document a known issue? If so, it should probably be documented in the Release Notes - that's where known issues are listed. Please let me know if I should change this BZ's component to the correct guide.
Comment 3 Roshni 2017-03-07 09:34:58 EST
https://bugzilla.redhat.com/show_bug.cgi?id=1229459#c40 was an issue during RHEL 6.8 testing which was fixed in coolkey build that came with RHEL 6.9. As per https://bugzilla.redhat.com/show_bug.cgi?id=1229459#c74, everything works as expected with the keyboard reader except that SC650 SCP02 was not detected. As per https://bugzilla.redhat.com/show_bug.cgi?id=1229459#c73 developers had confirmed that card is not supported any longer, so it do not need to be tested. So IMO there are no issues that needs to be documented for this bug.
Comment 4 Roshni 2017-03-07 09:46:41 EST
Sorry Aneta,

Just noticed this is RHEL 6.8 doc bug. In that case you need to document 2 points:

1. Keyboard hung and inconsistency in card detection.
2. When logged into the machine with a password and the smart card is not inserted I see following message continuously (2-3 times in a second) logged in /var/log/messages even when smart card is not inserted:
Mar  3 15:05:52 dhcp129-123 pcscd: commands.c:957:CmdGetSlotStatus Card absent or mute
Comment 5 Aneta Šteflová Petrová 2017-03-08 07:29:33 EST
Thanks for the clarification, Roshni. It looks like we should add this to the 6.8 Release Notes.
Comment 6 Aneta Šteflová Petrová 2017-03-13 06:23:09 EDT
Roshni, can you please review the description in the Doc Text field?

FYI, I didn't mention RHEL 6.8 anywhere in the text because if we publish the description in the RHEL 6.8 Release Notes, it should be clear that it is related only to this version.
Comment 7 Roshni 2017-03-13 08:31:27 EDT
Hi  Aneta,

I feel we can do without this line "The HP keyboard KUS1206 does not handle smart cards correctly and can become unresponsive". The rest of the description looks good to me.
Comment 8 Aneta Šteflová Petrová 2017-03-13 08:38:20 EDT
(In reply to Roshni from comment #7)
> Hi  Aneta,
> 
> I feel we can do without this line "The HP keyboard KUS1206 does not handle
> smart cards correctly and can become unresponsive". The rest of the
> description looks good to me.

Thanks for the review, Roshni.

To clarify: The first line of the description is converted to a title. It's used to summarize the issue. For example, you can see the result here: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/6.8_Release_Notes/known_issues_authentication_and_interoperability.html
Therefore, I'll keep the line. It should look okay when published on the Customer Portal.

Note You need to log in before you can comment on or make changes to this bug.