Bug 1309743 - Upgrading Sat6 fails in "katello-installer --upgrade" (401 - Unauthorized)
Upgrading Sat6 fails in "katello-installer --upgrade" (401 - Unauthorized)
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - Satellite (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity low
: ga
: 1.0
Assigned To: Derek Whatley
Tasos Papaioannou
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 10:19 EST by Thom Carlin
Modified: 2016-09-13 12:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:27:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2016-02-18 10:19:48 EST
Description of problem:

Upgrading RHCI Sat6 environment results in "401 Unauthorized"

Version-Release number of selected component (if applicable):

TP2 RC9

How reproducible:

100%

Steps to Reproduce:
1. Install RHCI ISO
2. Subscribe system
3. Update system
4. katello-service stop
5. katello-installer --upgrade

Actual results:

Error from katello-installer

Expected results:

Successful upgrade

Additional info:

Workaround: Don't upgrade in this manner

Traceback:

/var/log/foreman/production.log
2016-02-18 14:57:36 [I]   Parameters: {"apiv"=>"v2", "id"=>"production", "environment"=>{}}
2016-02-18 14:57:36 [I] invalid user
2016-02-18 14:57:36 [W] SSO failed
2016-02-18 14:57:36 [I]   Rendered api/v2/errors/unauthorized.json.rabl within api/v2/layouts/error_layout (0.7ms)
2016-02-18 14:57:36 [I] Filter chain halted as :authorize rendered or redirected
2016-02-18 14:57:36 [I] Completed 401 Unauthorized in 292ms (Views: 3.1ms | ActiveRecord: 1.4ms)

db_seed.log
rake aborted!
Please install the sqlite3 adapter: `gem install activerecord-sqlite3-adapter` (Could not find sqlite3 (~> 1.3.5) amongst [actionmailer-3.2.8, actionpack-3.2.8, active_model_serializers-0.9.3, activem
odel-3.2.8, activerecord-3.2.8, activeresource-3.2.8, activesupport-3.2.8, addressable-2.3.5, algebrick-0.4.0, ancestry-2.0.0, anemone-0.7.2, angular-rails-templates-0.1.2, ansi-1.4.3, apipie-params-0
.0.3, apipie-rails-0.2.5, archive-tar-minitar-0.5.2, arel-3.0.2, audited-3.0.0, audited-activerecord-3.0.0, autoparse-0.3.3, bastion-0.3.0.10, bigdecimal-1.1.0, builder-3.0.0, bundler-1.3.5, bundler_e
xt-0.3.0, commonjs-0.2.7, daemons-1.1.4, deep_cloneable-2.0.0, deface-0.7.2, diff-lcs-1.1.3, docker-api-1.17.0, domain_name-0.5.24, dynflow-0.7.7.9, egon-0.4.8, erubis-2.7.0, excon-0.38.0, extlib-0.9.
16, faraday-0.8.8, fast_gettext-0.8.0, fog-1.24.0, fog-brightbox-0.0.1, fog-core-1.24.0, fog-json-1.0.0, fog-radosgw-0.0.3, fog-sakuracloud-0.1.1, fog-softlayer-0.3.9, fog-xml-0.1.0, foreigner-1.4.2, 
foreman-tasks-0.6.15.7, foreman_bootdisk-4.0.2.13, foreman_discovery-2.0.0.19, foreman_docker-1.2.0.22, foreman_gutterball-0.0.1.9, foreman_hooks-0.3.7, foretello_api_v21-0.0.1, formatador-0.2.1, frie
ndly_id-4.0.10.1, fusor_server-0.0.1, fusor_ui-0.0.1, gettext_i18n_rails-0.10.0, gettext_i18n_rails_js-0.0.8, google-api-client-0.6.4, haml-3.1.6, haml-rails-0.3.4, hashr-0.0.22, hike-1.2.1, hooks-0.2
.2, hpricot-0.8.6, http-cookie-1.0.2, i18n-0.6.0, i18n_data-0.2.7, io-console-0.3, ipaddress-0.8.0, journey-1.0.4, jquery-rails-2.0.2, jquery-ui-rails-4.0.2, json-1.5.5, justified-0.0.4, jwt-0.1.8, ka
tello-2.2.0.73, launchy-2.3.0, ldap_fluff-0.3.2, less-2.5.1, less-rails-2.5.0, little-plugger-1.1.3, logging-1.8.1, mail-2.4.4, mechanize-2.7.2, mime-types-1.19, minitest-2.5.1, multi_json-1.8.2, mult
ipart-post-1.2.0, net-http-digest_auth-1.4, net-http-persistent-2.7, net-ldap-0.3.1, net-scp-1.1.0, net-ssh-2.9.2, nokogiri-1.5.11, ntlm-http-0.1.1, oauth-0.4.7, passenger-4.0.18, pg-0.12.2, po_to_jso
n-0.0.7, polyglot-0.3.3, qpid_messaging-0.30.0, rabl-0.9.0, rack-1.4.1, rack-cache-1.2, rack-protection-1.2.0, rack-ssl-1.3.2, rack-test-0.6.1, rails-3.2.8, railties-3.2.8, rake-0.9.2.2, rbovirt-0.0.2
9, rbvmomi-1.6.0, rdoc-3.9.5, redhat_access-0.2.3, redhat_access_lib-0.0.4, ref-1.0.0, rest-client-1.6.7, robotex-1.0.0, ruby-libvirt-0.5.1, ruby2ruby-2.0.1, ruby_parser-3.1.1, rubyzip-1.1.7, runcible
-1.3.5, safemode-1.2.1, sass-3.2.13, scoped_search-2.7.1, secure_headers-1.3.3, sequel-3.45.0, sexp_processor-4.1.3, signet-0.4.5, sinatra-1.3.2, sprockets-2.10.1, sshkey-1.6.0, strong_parameters-0.2.
1, therubyracer-0.11.0beta5, thor-0.18.1, tilt-1.3.3, tire-0.6.2, treetop-1.4.10, trollop-2.0, tzinfo-0.3.33, unf-0.1.3, unf_ext-0.0.6, uuidtools-2.1.3, validates_lengths_from_database-0.2.0, webrobot
s-0.1.1, wicked-1.1.0, will_paginate-3.0.2])

Tasks: TOP => db:abort_if_pending_migrations => environment
(See full trace by running task with --trace)
API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.
Seeding /usr/share/foreman/db/seeds.d/03-auth_sources.rb
Seeding /usr/share/foreman/db/seeds.d/03-permissions.rb
Seeding /usr/share/foreman/db/seeds.d/03-roles.rb
Seeding /usr/share/foreman/db/seeds.d/04-admin.rb
Seeding /usr/share/foreman/db/seeds.d/05-taxonomies.rb
Seeding /usr/share/foreman/db/seeds.d/06-architectures.rb
Seeding /usr/share/foreman/db/seeds.d/07-config_templates.rb
Seeding /usr/share/foreman/db/seeds.d/08-partition_tables.rb
Seeding /usr/share/foreman/db/seeds.d/10-installation_media.rb
Seeding /usr/share/foreman/db/seeds.d/11-smart_proxy_features.rb
Seeding /usr/share/foreman/db/seeds.d/13-compute_profiles.rb
Seeding /usr/share/foreman/db/seeds.d/15-bookmarks.rb
Seeding /usr/share/foreman/db/seeds.d/16-mail_notifications.rb
Seeding /opt/rh/ruby193/root/usr/share/gems/gems/foreman-tasks-0.6.15.7/db/seeds.d/20-foreman_tasks_permissions.rb
Seeding /opt/rh/ruby193/root/usr/share/gems/gems/foreman_bootdisk-4.0.2.14/db/seeds.d/50-bootdisk_templates.rb
Seeding /opt/rh/ruby193/root/usr/share/gems/gems/foreman_discovery-2.0.0.23/db/seeds.d/50_discovery_templates.rb
Seeding /opt/rh/ruby193/root/usr/share/gems/gems/foreman_discovery-2.0.0.23/db/seeds.d/60_discovery_proxy_feature.rb
Seeding /opt/rh/ruby193/root/usr/share/gems/gems/foreman-tasks-0.6.15.7/db/seeds.d/61-foreman_tasks_bookmarks.rb
All seed files executed

katello-installer --upgrade
Starting networking setup
Networking setup has finished
NTP sync host is ok
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_mongo...
Upgrade Step: migrate_pulp...
Upgrade Step: start_httpd...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [....................................................................................................................]
  The full log is at /var/log/katello-installer/katello-installer.log
Starting configuration...
Starting host creation
/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/abstract_response.rb:48:in `return!': 401 Unauthorized (RestClient::Unauthorized)
	from /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:230:in `process_result'
	from /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:178:in `block in transmit'
	from /usr/share/ruby/net/http.rb:852:in `start'
	from /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:172:in `transmit'
	from /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'
	from /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:33:in `execute'
	from /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/resource.rb:51:in `get'
	from /usr/share/gems/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:279:in `call_client'
	from /usr/share/gems/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:210:in `http_call'
	from /usr/share/gems/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:160:in `call'
	from /usr/share/gems/gems/apipie-bindings-0.0.11/lib/apipie_bindings/action.rb:16:in `call'
	from /usr/share/katello-installer/hooks/lib/foreman.rb:53:in `show_or_ensure'
	from /usr/share/katello-installer/hooks/lib/host_seeder.rb:14:in `seed'
	from /usr/share/katello-installer/hooks/post/10-setup_provisioning.rb:12:in `block (4 levels) in load'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:32:in `instance_eval'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:32:in `block (4 levels) in load'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hook_context.rb:13:in `instance_exec'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hook_context.rb:13:in `execute'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:49:in `block in execute'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:47:in `each'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:47:in `execute'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:339:in `block in run_installation'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/exit_handler.rb:24:in `call'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/exit_handler.rb:24:in `exit'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:122:in `exit'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:338:in `run_installation'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:109:in `execute'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:116:in `run'
	from /usr/sbin/katello-installer:46:in `<main>'
Comment 1 Thom Carlin 2016-02-18 10:58:46 EST
tail katello-installer.log
[ INFO 2016-02-18 15:18:44 main] Executing hooks in group post
[DEBUG 2016-02-18 15:18:44 main] Hook /usr/share/katello-installer/hooks/post/10-post_install.rb returned nil

Other excerpts:
pulp[26077]: gofer.messaging.adapter.qpid.connection:ERROR: connect: qpid+ssl://sat6_fqdn:5671, failed: [Errno 111] Connection refused
Comment 7 Jason Montleon 2016-08-02 15:18:05 EDT
Ran satellite-installer --upgrade on the latest iso and it completed successfully.
Comment 8 Tasos Papaioannou 2016-08-23 12:21:44 EDT
Verified on QCI-1.0-RHEL-7-20160819.t.0.
Comment 10 errata-xmlrpc 2016-09-13 12:27:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.