Bug 1309803 - openvswitch 2.4 Does Not Support IPv6 Endpoints for VXLAN/GRE Tunnels
openvswitch 2.4 Does Not Support IPv6 Endpoints for VXLAN/GRE Tunnels
Status: CLOSED DUPLICATE of bug 1100360
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Thadeu Lima de Souza Cascardo
Ofer Blaut
Depends On: 1100360 1283886
  Show dependency treegraph
Reported: 2016-02-18 13:15 EST by Dan Sneddon
Modified: 2017-11-06 19:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-03-03 09:54:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dan Sneddon 2016-02-18 13:15:07 EST
Description of problem:
openvswitch does not support IPv6 tunnel endpoints in version 2.4. Although version 2.6 does support IPv6 tunnels, it also requires a new kernel.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Deploy Red Hat OpenStack Platform with IPv6 network isolation and VXLAN tunnels

Actual results:
Open vSwitch will not start properly, and cannot handle IPv6 endpoints for tunnels.

Expected results:
Open vSwitch should handle an IPv6 underlay network.

Additional info:
The 2.6 version of Open vSwitch will also require a newer kernel, so there is a dependency on bumping the RHEL version in addition to upgrading OVS before we can support IPv6 tunneling endpoints.

The current workaround involves using and isolated IPv4 network for tunneling, even if IPv6 is used on other networks.
Comment 2 Thadeu Lima de Souza Cascardo 2016-03-03 08:44:08 EST
Hi, Dan.

We track this with a bug of our own, for RHEL. Should someone in your team be assigned to it?

Comment 3 Nir Yechiel 2016-03-03 09:54:53 EST

*** This bug has been marked as a duplicate of bug 1100360 ***

Note You need to log in before you can comment on or make changes to this bug.