Bug 130985 - mc does not redraw screen properly on return of xterm focus
Summary: mc does not redraw screen properly on return of xterm focus
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: mc   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-26 14:27 UTC by George Toft
Modified: 2013-07-02 23:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 13:16:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Toft 2004-08-26 14:27:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
When runninb mc in an xterm, when xterm is covered with another window
or virtual desktop and focus is subsequently returned to that xterm,
the right pane is distored.

This bug only happens when the mc cursor is in the left pane and a
portion of the left pane was covered and must be redrawn.

I tried this using gnome and IceWM.

Note: If cursor is in right pane, there is a one character distortion
on the far right side of the xterm.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Launch xterm
2.  execute: mc
3.  Place cursor in left pane
4.  Launch another app and cover the xterm
5.  Return focus to xterm with Alt-Tab or dragging other app away from
xterm.
6.  View distorion in mc

    

Actual Results:  Right pane is distorted.

Expected Results:  Right pane should not be distorted.

Additional info:

Work around: press Ctrl-U twice.  This forces a redraw of the entire
screen as it swiches the left & right panes.  The second Ctrl-U
returns the display to previous configuration.

Comment 1 Thomas E. Dickey 2004-08-28 00:33:11 UTC
This sounds like the repainting bug fixed in patch #194.
(I don't know what version of xterm is being discussed -
"xterm -v" would tell).

Comment 2 Jindrich Novy 2004-10-11 12:33:03 UTC
George, this works for me with xterm-192 and xterm-179. What is the
version of xterm and 'mc --version' ? What application do you launch
to see the distortion?

Comment 3 Jindrich Novy 2004-10-26 14:45:38 UTC
ping?

Comment 4 George Toft 2004-10-27 14:12:03 UTC
oops - sorry about that.

$ rpm -qi xterm
Name        : xterm                        Relocations: (not relocatable)
Version     : 191                               Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Fri 18 Jun
2004 02:37:10 PM MST


$ rpm -qi mc
Name        : mc                           Relocations: (not relocatable)
Version     : 4.6.0                             Vendor: Red Hat, Inc.
Release     : 17.fc2                        Build Date: Sat 21 Aug
2004 10:28:28 AM MST
Install Date: Sun 12 Sep 2004 02:51:01 PM MST      Build Host:
tweety.build.redhat.com


Comment 5 Jindrich Novy 2004-10-30 08:45:15 UTC
Could you try it with some recent mc release, mc-4.6.1-0.8? I'm still
unable to reproduce the problem. The easier way to refresh mc desktop
is to press Ctrl-L.

Comment 6 George Toft 2004-11-01 03:29:50 UTC
The latest version available from Fedora
http://download.fedora.redhat.com/pub/fedora/linux/core/test/2.92/i386/os/Fedora/RPMS/
is mc-4.6.1-0.5.i386.rpm.

The "Official Homepage" for mc (http://www.ibiblio.org/mc/) is quite
outdated.  The other "Official Homepage"
(http://www.gnome.org/projects/mc/) does not exist.

Please provide link so I can try new version requsted.

Thanks.

George


Comment 7 Jindrich Novy 2004-11-01 12:25:55 UTC
George, this is the link to the rpm:
ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/mc-4.6.1-0.8.i386.rpm

Jindrich

Comment 8 George Toft 2004-11-01 14:38:11 UTC
# rpm -Uvh mc-4.6.1-0.8.i386.rpm 
warning: mc-4.6.1-0.8.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing...               
########################################### [100%]
   1:mc                    
########################################### [100%]


Still has same problem.  If you are not experiencing it, perhaps there
are other settings we need to look at?


Comment 9 Jindrich Novy 2004-11-08 13:16:31 UTC
Hi George, unfortunately I have no idea where the problem is. Could
you please report it to the upstream mailng list (mc@gnome.org) ?
Because I can't reproduce it I can't fix it. If you write an email to
upstream, there will be bigger chance that anybody can reproduce it or
fix it.

The official mc homepage looks rather outdated at the first look, but
there's a big traffic in mailing lists (mc-devel and mc). Furthermore
you can find a solution in mailing list archives.

Jindrich


Note You need to log in before you can comment on or make changes to this bug.