Bug 1309967 - Error while deploying BRMS on EAP 6.4 in domain mode
Error while deploying BRMS on EAP 6.4 in domain mode
Status: NEW
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 01:14 EST by deepalic
Modified: 2016-02-22 09:41 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EAP Server log (513.16 KB, text/plain)
2016-02-19 01:14 EST, deepalic
no flags Details

  None (edit)
Description deepalic 2016-02-19 01:14:48 EST
Created attachment 1128451 [details]
EAP Server log

Description of problem:
I am following the instructions available on https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BRMS/6.2/html/Installation_Guide/Installing_BRMS_in_the_Domain_Mode.html for deploying BRMS on EAP in domain mode. But the the deployed is rolled back because of errors. 

Version-Release number of selected component (if applicable):
BRMS 6.2.0, EAP 6.4.0


How reproducible:
Consistently occurring.


Steps to Reproduce:
1.Download EAP v6.4 zip from the downloads page. Extract it. 
2.Download BRMS deployable on EAP zip from the downloads page. Extract it. 
3.Follow the instructions on https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BRMS/6.2/html/Installation_Guide/Installing_BRMS_in_the_Domain_Mode.html for deploying BRMS on EAP.

Actual results:
The output on the EAP CLI is:
 ./jboss-cli.sh
You are disconnected at the moment. Type 'connect' to connect to the server or 'help' for the list of supported commands.
[disconnected /] connect
[domain@localhost:9999 /] deploy --all-server-groups /root/deepali/JBOSS/BRMS_EAP_domain/deployable/jboss-eap-6.4/standalone/deployments/business-central.war
/root/deepali/JBOSS/BRMS_EAP_domain/deployable/jboss-eap-6.4/standalone/deployments/business-central.war is a directory.
[domain@localhost:9999 /] deploy --all-server-groups /root/deepali/JBOSS/BRMS_EAP_domain/deployable/jboss-eap-6.4/standalone/deployments/business-central.war/business-central.war
JBAS010839: Operation failed or was rolled back on all servers.

Expected results:
The deployment should succeed.


Additional info:
The components from the same BRMS zip work with EAP 6.4 in standalone mode.
Comment 2 deepalic 2016-02-22 09:41:41 EST
Similar issue is also observed while deploying the war on BPM Suite with EAP in domain mode.

Note You need to log in before you can comment on or make changes to this bug.