Bug 1310071 - Importing external network with name duplicated by existing network causes unhandled UI error
Importing external network with name duplicated by existing network causes un...
Status: CLOSED DUPLICATE of bug 1310074
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 06:37 EST by Marcin Mirecki
Modified: 2016-02-19 06:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 06:41:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Marcin Mirecki 2016-02-19 06:37:47 EST
When a network from an external provider is imported, and there already exists a network with such a name in the system, the UI breaks due to an unhandled error.

Steps to Reproduce:
1. Create network <network_name> in ovirt.
2. Add external network provider containing a network <network_name>.
3. Open external networks import dialog.
4. Try to import the network with duplicated name <network_name>
5. Unhandled GWT exception occurs.
 
Cause:

ImportNetworksModel.onProviderChosen -> onSuccess(Object model, Object returnValue)  line 153
The return value passed in, is a map external_network:{set of data centers}
For a duplicated network {set of data centers} is empty, which will cause an NPE exception when the Import button is pressed.
This will be in:
ImportNetworksModel.onImport (line 244) -> externalNetwork.getDataCenters().getSelectedItem()
Comment 1 Marcin Mirecki 2016-02-19 06:41:06 EST
Duplicate of 1310074
(browser refresh problems)

*** This bug has been marked as a duplicate of bug 1310074 ***

Note You need to log in before you can comment on or make changes to this bug.