Bug 1310074 - Importing external network with name duplicated by existing network causes unhandled UI error
Importing external network with name duplicated by existing network causes un...
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Dominik Holler
Pavel Stehlik
:
: 1310071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 06:39 EST by Marcin Mirecki
Modified: 2016-11-10 10:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 10:25:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
Error message (13.17 KB, image/png)
2016-11-10 10:23 EST, Dominik Holler
no flags Details

  None (edit)
Description Marcin Mirecki 2016-02-19 06:39:37 EST
Importing external network with name duplicated by existing network causes unhandled UI error

When a network from an external provider is imported, and there already exists a network with such a name in the system, the UI breaks due to an unhandled error.

Steps to Reproduce:
1. Create network <network_name> in ovirt.
2. Add external network provider containing a network <network_name>.
3. Open external networks import dialog.
4. Try to import the network with duplicated name <network_name>
5. Unhandled GWT exception occurs.
 
Cause:

ImportNetworksModel.onProviderChosen -> onSuccess(Object model, Object returnValue)  line 153
The return value passed in, is a map external_network:{set of data centers}
For a duplicated network {set of data centers} is empty, which will cause an NPE exception when the Import button is pressed.
This will be in:
ImportNetworksModel.onImport (line 244) -> externalNetwork.getDataCenters().getSelectedItem()
Comment 1 Marcin Mirecki 2016-02-19 06:41:06 EST
*** Bug 1310071 has been marked as a duplicate of this bug. ***
Comment 2 Sandro Bonazzola 2016-05-02 06:06:33 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Yaniv Lavi (Dary) 2016-05-23 09:21:22 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Yaniv Lavi (Dary) 2016-05-23 09:24:15 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Dominik Holler 2016-11-10 10:23 EST
Created attachment 1219452 [details]
Error message
Comment 6 Dominik Holler 2016-11-10 10:25:51 EST
The attemt to reproduce this bug results in a error message, see  attachment 1219452 [details]. So this bug seems to be fixed already.

Note You need to log in before you can comment on or make changes to this bug.