Bug 1310207 - tomcatjss conflicts with tomcat-native
tomcatjss conflicts with tomcat-native
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: tomcat-native (Show other bugs)
epel7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Lorenzo Dalrio
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 13:05 EST by lejeczek
Modified: 2016-02-22 08:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 13:36:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2016-02-19 13:05:51 EST
Description of problem:

--> Finished Dependency Resolution
Error: tomcatjss conflicts with tomcat-native-1.1.34-1.el7.x86_64
 You could try using --skip-broken to work around the problem

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Lorenzo Dalrio 2016-02-19 13:36:18 EST
This is the output of repoquey -i tomcatjss:

Name        : tomcatjss
Version     : 7.1.2
Release     : 1.el7
Architecture: noarch
Size        : 49616
Packager    : CentOS BuildSystem <http://bugs.centos.org>
Group       : System Environment/Libraries
URL         : http://pki.fedoraproject.org/
Repository  : base
Summary     : JSSE implementation using JSS for Tomcat
Source      : tomcatjss-7.1.2-1.el7.src.rpm
Description :
A Java Secure Socket Extension (JSSE) implementation
using Java Security Services (JSS) for Tomcat 7.

NOTE:  The 'tomcatjss' package conflicts with the 'tomcat-native' package
       because it uses an underlying NSS security model rather than the
       OpenSSL security model, so these two packages may not co-exist.


As you can see this is expected behavior.
Comment 2 lejeczek 2016-02-22 04:42:09 EST
how does one do, do you/Redhat/Centos advise package maintainers to choose one over the other?
I would like to install guacamole.noarch when it brakes, should I move this report to guacamole?
Comment 3 Lorenzo Dalrio 2016-02-22 08:57:27 EST
If you remove tomcatjss your problem should be solved. guacamole.noarch depends on tomcat-native.

Note You need to log in before you can comment on or make changes to this bug.