Bug 1310238 - [extras] New package openscap-daemon
[extras] New package openscap-daemon
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity medium (vote)
: 6.1.1
: --
Assigned To: satellite6-bugs
: Reopened, Triaged
Depends On:
Blocks: 1296594 1313485
  Show dependency treegraph
 
Reported: 2016-02-19 15:18 EST by Martin Preisler
Modified: 2017-01-12 16:32 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 16:32:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Preisler 2016-02-19 15:18:00 EST
Description of problem:
Need a new package in RHEL7 extras called "openscap-daemon". We already have a spec file in Fedora EPEL7, see http://pkgs.fedoraproject.org/cgit/rpms/openscap-daemon.git/tree/?h=epel7

This package is required for the "atomic scan" functionality, see https://martin.preisler.me/2015/11/atomic-scan-and-openscap-daemon/

Upstream repo: https://github.com/OpenSCAP/openscap-daemon/
Upstream web: https://www.open-scap.org/tools/openscap-daemon/

Version-Release number of selected component (if applicable):
7.2

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Peter Vrabec 2016-02-29 07:09:16 EST
Expected devel owner: Martin Preisler (mpresile@redhat.com)
Comment 11 RHEL Product and Program Management 2016-03-10 10:15:43 EST
Product Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 12 Martin Preisler 2016-03-10 10:31:58 EST
I am reopening this because I find the decision quite strange.

OpenSCAP-daemon is too low level in the stack to be in Satellite or Cloudforms channels. We are already using it in Atomic. We plan to use it in Sat6, Cloudforms, Cockpit and other projects to unify the OpenSCAP scanning for generic targets. Are we expected to push the package to every one of these channels?
Comment 16 Bryan Kearney 2016-07-26 15:04:06 EDT
Moving 6.2 bugs out to sat-backlog.

Note You need to log in before you can comment on or make changes to this bug.